xpra icon
Bug tracker and wiki

Opened 4 months ago

Closed 4 months ago

Last modified 3 months ago

#1764 closed enhancement (fixed)

webp YUV420P color subsampling

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 2.3
Component: encodings Version: trunk
Keywords: Cc:

Description

Follow up from #1438: we could decode webp to yuv if we encoded it from yuv data (the code currently only supports rgb input) and told the client that it can safely use yuv without losing accuracy.

This should give us a significant performance and compression boost (use with quality settings lower than ~50%?), maybe even enough to supplant jpeg for all settings?

We would need a csc step... and not one managed by the video pipeline setup code. Maybe just hardcode a dependency on libyuv for this feature?

Change History (2)

comment:1 Changed 4 months ago by Antoine Martin

Milestone: future2.3
Resolution: fixed
Status: newclosed

Done in r18334 (see long commit message) since it was easy enough to add using webp's WebPPictureARGBToYUVA for colorspace conversion.

It would be nice to also paint YUVA: #1765.

comment:2 Changed 3 months ago by Antoine Martin

Caused a regression: #1769

Note: See TracTickets for help on using tickets.