xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 2 years ago

Last modified 23 months ago

#177 closed task (fixed)

how to run tests?

Reported by: onlyjob Owned by: Antoine Martin
Priority: trivial Milestone: 0.15
Component: core Version: trunk
Keywords: Cc:

Description

Sorry for troubles, this is basically just a question.

Could you please kindly advise how to run tests?

I get error:

  File "tests/yatest.py", line 356, in <module>
    YaTest().main()
  File "tests/yatest.py", line 99, in main
    magic_invoke = py.magic.invoke
  File "/usr/lib/python2.6/dist-packages/py/_apipkg.py", line 112, in __makeattr
    raise AttributeError(name)
AttributeError: magic

What command do you use?

Thank you.

Change History (11)

comment:1 Changed 5 years ago by Antoine Martin

Milestone: 0.5future
Status: newaccepted
Version: 0.4.0trunk

These tests have not been used in years...

I may try to do something about it one day, don't hold your breath.

comment:2 Changed 5 years ago by onlyjob

I see, thank you for your comment.
I thought I just couldn't run them due to my ignorance in python so I feel much better now. :)

comment:3 Changed 3 years ago by Antoine Martin

Milestone: future0.15

As part of #660, let's try to at least have basic regression tests and unit tests for the next release.

comment:4 Changed 3 years ago by Antoine Martin

As of r7683, we have some simple unit tests and we run them as part of the %check step of the rpmbuild process.
I will continue to add more there, and re-work at least some of the other tests into another new test tree. (this one for tests that require spawning a server and interacting with it, much more tricky to get right!)

comment:5 Changed 2 years ago by Antoine Martin

Tests needed fixes in r7854 after some tests were added which required server components (and those are not built with python3).

comment:6 Changed 2 years ago by Antoine Martin

Had to disable tests on centos6 (r7915) to be able to build rpms..

comment:7 Changed 2 years ago by Antoine Martin

Had to disable the new xor test in r9087 (not sure why - maybe we can't test cython modules?)

Last edited 2 years ago by Antoine Martin (previous) (diff)

comment:8 Changed 2 years ago by Antoine Martin

Status: acceptednew

The cython tests were failing because we were testing with the wrong python interpreter when spawning a subprocess, r9187 fixes that amongst other things.
Many other small fixes and tests added in r9186, r9191 (and minor issues fixed along the way).

comment:9 Changed 2 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

This will do for now, all the unit tests are being run as part of the rpmbuild check stage, and we can schedule some more thorough tests for the next release, see #847.

comment:10 Changed 23 months ago by Antoine Martin

Minor build fixes for Fedora r9210: verify the python3 libs required are installed using BuildRequires statements.

comment:11 Changed 23 months ago by Antoine Martin

Many more tests added to trunk, see r9246, r9247, r9248, r9249, r9253, r9255

Note: See TracTickets for help on using tickets.