xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#1779 closed defect (fixed)

Traceback when running Xpra Stop

Reported by: J. Max Mena Owned by: Antoine Martin
Priority: critical Milestone:
Component: server Version: trunk
Keywords: Cc:


My client and server are Fedora 26 machines running trunk r18658.

Server is started normally with xpra start :13 --bind-tcp= --start-new-commands=yes --start-child=xterm --start-via-proxy=no --systemd-run=no --no-daemon. Attempting to stop the server with xpra stop both from inside the session's Xterm and in a separate terminal window SSHd into the server, it fails with this traceback:

error in hello packet
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/client/client_base.py", line 730, in _process_hello
    if not self.server_connection_established():
  File "/usr/lib64/python2.7/site-packages/xpra/client/gobject_client_base.py", line 158, in server_connection_established
    return CommandConnectClient.server_connection_established(self)
  File "/usr/lib64/python2.7/site-packages/xpra/client/gobject_client_base.py", line 141, in server_connection_established
  File "/usr/lib64/python2.7/site-packages/xpra/client/gobject_client_base.py", line 476, in do_command
    if not self.server_client_shutdown:
AttributeError: 'StopXpraClient' object has no attribute 'server_client_shutdown'
error processing hello packet from server: 'StopXpraClient' object has no attribute 'server_client_shutdown'

Assuming one started the server with --no-daemon then one could use a ctrl + c and that'll stop the server. Otherwise one has to manually kill the process.

Change History (3)

comment:1 Changed 3 weeks ago by Antoine Martin

Resolution: fixed
Status: newclosed

Caused by one of the huge refactorings from #1761, fixed in r18659.

comment:2 Changed 3 weeks ago by J. Max Mena

Unfortunately r18659 has a traceback when attempting to connect.

comment:3 Changed 3 weeks ago by J. Max Mena

Followed up in #1780

Note: See TracTickets for help on using tickets.