xpra icon
Bug tracker and wiki

Opened 7 months ago

Closed 7 months ago

#1780 closed defect (fixed)

Traceback when attaching

Reported by: J. Max Mena Owned by: Antoine Martin
Priority: critical Milestone: 2.3
Component: client Version: trunk
Keywords: Cc:

Description

My client and server are Fedora 26 machines running trunk r18658.

The server was started with xpra start :13 --bind-tcp=0.0.0.0: --start-new-commands=yes --start-child=xterm --start-via-proxy=no --systemd-run=no --no-daemon. Attempting to attach fails with this traceback:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/client/client_base.py", line 731, in _process_hello
    if not self.server_connection_established():
  File "/usr/lib64/python2.7/site-packages/xpra/client/ui_client_base.py", line 279, in server_connection_established
    if not XpraClientBase.server_connection_established(self):
  File "/usr/lib64/python2.7/site-packages/xpra/client/client_base.py", line 749, in server_connection_established
    if not self.parse_server_capabilities():
  File "/usr/lib64/python2.7/site-packages/xpra/client/ui_client_base.py", line 288, in parse_server_capabilities
    if not c.parse_server_capabilities(self):
  File "/usr/lib64/python2.7/site-packages/xpra/client/client_base.py", line 768, in parse_server_capabilities
    self.server_client_shutdown = c.boolget("client-shutdown", True)
AttributeError: type object 'FilePrintMixin' has no attribute 'boolget'
2018-03-01 10:16:40,996 error processing hello packet from server: type object 'FilePrintMixin' has no attribute 'boolget'
2018-03-01 10:16:41,006 Connection lost

Change History (1)

comment:1 Changed 7 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Caused by r18659, fixed in r18660.

Note: See TracTickets for help on using tickets.