xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 2 months ago

#1783 closed defect (invalid)

Cannot get "Get started" to work

Reported by: yannsalmon Owned by: yannsalmon
Priority: blocker Milestone: 2.3
Component: server Version: 2.2.x
Keywords: Cc:

Description

Hello,
I am completely new to Xpra and I am trying to run the basic example

xpra start ssh:host --start=xterm

Both machines are running XUbuntu 16.04 and xpra v2.2.5-r18663.

Running the above command on the client leads to "Failed to receive anything". On the server, the lo says :

2018-03-13 23:11:47,009 cannot access python uinput module:
2018-03-13 23:11:47,009  No module named uinput
/usr/lib/xorg/Xorg.wrap: Only console users are allowed to run the X server
xpra initialization error:
 Xorg: did not provide a display number using displayfd

I read about the error regarding X server and found that I should modify /etc/X11/Xwrapper.config to allow anybody to run the X server.

Is this right ?

Anyway, I did so to test, but connection still fails ; the server now has

2018-03-13 23:29:52,732 cannot access python uinput module:
2018-03-13 23:29:52,732  No module named uinput
(EE) 
Fatal server error:
(EE) The '-logfile' option cannot be used with elevated privileges.
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
(EE) 
xpra initialization error:
 Xorg: did not provide a display number using displayfd

What is going on ?

Xorg -version gives :

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0

Change History (7)

comment:1 Changed 5 months ago by Antoine Martin

Owner: changed from Antoine Martin to yannsalmon

The easiest thing to do on Ubuntu is to use Xvfb instead of Xdummy (as Ubuntu messed up the X11 permissions).
Try to modify /etc/xpra/conf.d/55_server_x11.conf: comment out the Xorg line and uncomment Xvfb.
If somehow that does not help, try specifying a display to use:

xpra start ssh:host --start=xterm :100

And keep an eye on your system log.

comment:2 Changed 5 months ago by Antoine Martin

Milestone: 2.3
Resolution: needinfo
Status: newclosed

comment:3 Changed 2 months ago by kaefert

Resolution: needinfo
Status: closedreopened

I seem to have run into the same issue.
After failing to get function from the xpra version included in Linux Mint 18.3 (~ Ubuntu 16.04) = xpra 0.15.8+dfsg-1
for details see also:
http://lists.devloop.org.uk/pipermail/shifter-users/2018-June/002133.html

I upgraded to xpra 2.3.1-r19533-1 found in deb https://xpra.org/ xenial main

With this versionI get these errors:

cannot access python uinput module:
No module named uinput

And

$ xpra start --start=gnome-terminal :100
Warning: invalid option: 'scaling'
2018-06-06 00:50:43,857 server failure: disconnected before the session could be established
2018-06-06 00:50:43,857 server requested disconnect: server error (failed to start a new session)
Warning: cannot use the system proxy for 'start' subcommand,
 unknown general failure
 more information may be available in your system log
Warning: invalid option: 'scaling'

comment:4 Changed 2 months ago by Antoine Martin

Status: reopenednew

cannot access python uinput module:
No module named uinput

This is optional. This message is informational, not even a warning or error.

Warning: invalid option: 'scaling'

This warning is caused by leftovers from your old package. Purge it and it will go away.

Warning: cannot use the system proxy for 'start' subcommand,
unknown general failure
more information may be available in your system log

Like the message says: more information will be available in your system log.
This is warning and it is not fatal.

There aren't enough details for me to reproduce, please see wiki/ReportingBugs.

comment:5 Changed 2 months ago by kaefert

Hello!

Thanks for your reply!
I purged my xpra installation and installed it again. now it seems to work fine, at least locally by running

xpra start --start=gnome-terminal

in one germinal and

xpra attach

in another one. I'll try doing the same thing using 2 different machines next.

comment:6 Changed 2 months ago by kaefert

Ah, what I forgot to mention what's probably also important for others trying to replicate my problem and or solution: before installing xpra again I also deleted the .xpra directory in my home folder.

comment:7 Changed 2 months ago by Antoine Martin

Resolution: invalid
Status: newclosed

.. before installing xpra again I also deleted the .xpra directory in my home folder.

This should not make any difference unless you created an xpra.conf file in there with some seriously messed up options.

Closing as invalid as our packages, installed correctly, work fine.

Note: See TracTickets for help on using tickets.