xpra icon
Bug tracker and wiki

Opened 2 weeks ago

Closed 11 days ago

#1803 closed defect (fixed)

Pulseaudio selecting incorrect default device

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: major Milestone: 2.3
Component: sound Version: trunk
Keywords: Cc:

Description

For reference my client and server are Fedora 26 machines running trunk r18990 built from source.

When I first spin up a server and client I get no audio. However I don't get any relevant tracebacks, but upon initial connection both the server and client print:

2018-04-05 09:34:24,844 sound output Warning: failed to identify the pulseaudio default device to use
2018-04-05 09:34:24,844 sound output  list indices must be integers, not str

Pulling up pavucontrol on the server shows that the recording device on the server is set to the wrong device. As a quick workaround you can select Monitor of Xpra Speaker under recording device and get your sound back.

Change History (2)

comment:1 Changed 2 weeks ago by Antoine Martin

Milestone: 2.3
Owner: changed from Antoine Martin to J. Max Mena

Looks like this was caused by r18979 + r18980, should be fixed in r18991.

comment:2 Changed 11 days ago by J. Max Mena

Resolution: fixed
Status: newclosed

That fixed it - closing.

Note: See TracTickets for help on using tickets.