xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#1806 closed defect (invalid)

On 3-monitor screen, 'shadow'-ing "Disconnects" one screen

Reported by: stdedos Owned by: Antoine Martin
Priority: major Milestone: 2.3
Component: server Version: 2.2.x
Keywords: Cc:

Description

I am trying to shadow a 3-monitor screen.
After leaving / locking the desktop, I reconnect to it. It is possible that screens go on low-energy standby.

On connection, although viewport size is calculated correctly, the rightmost monitor is non-existent. On xpra shadow host all windows are migrated to the middle monitor, and on xpra shadow clinet rightmost part of xpra shadow is black.

sntentos@optiplex-9010 [2018-04-10 11:35:22]:~$ xrandr -q
Screen 0: minimum 8 x 8, current 5520 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm panning 3600x1050+0+0 tracking 5520x1080+0+0 border 0/0/0/0
   1680x1050     59.88*+  59.95  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
DP-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+1680+0 (normal left inverted right x axis y axis) 527mm x 296mm panning 3840x1080+1680+0 tracking 5520x1080+0+0 border 0/0/0/0
   1920x1080     60.00*+  59.94    50.00    60.05    60.00    50.04  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-1 disconnected (normal left inverted right x axis y axis)
sntentos@optiplex-9010 [2018-04-10 11:36:16]:~$ xrandr -q
Screen 0: minimum 8 x 8, current 5520 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1680x1050+0+30 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050     59.88*+  59.95  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
DP-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+3600+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00*+  59.94    50.00    60.05    60.00    50.04  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-1 connected 1920x1080+1680+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00*+
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
sntentos@optiplex-9010 [2018-04-10 12:26:14]:~$ 

I suspect that "rightmost monitor is not activated from its sleep"

Attachments (5)

xpra-log.log (3.5 KB) - added by stdedos 5 months ago.
xpra-log-2.log (6.8 KB) - added by stdedos 5 months ago.
xpra-attach.log (535.6 KB) - added by stdedos 5 months ago.
xpra-logs.tar.bz2 (13.7 KB) - added by stdedos 5 months ago.
xpra-shadow-win10.tar.bz2 (604.3 KB) - added by stdedos 5 months ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 5 months ago by Antoine Martin

Milestone: 2.3
Owner: changed from Antoine Martin to stdedos

Please try the latest beta builds: https://xpra.org/beta, which should give you a window for each monitor: #1801. This should make it easier to figure out what is being detected and what isn't.
If you are still having problems, please post the server's "-d shadow,geometry" debug output.

Last edited 5 months ago by Antoine Martin (previous) (diff)

comment:2 Changed 5 months ago by stdedos

Is it possible to generate a x64 windows beta build? Plink crashes with MSVCP140.dll error @ Windows 10 x64 laptop

comment:3 Changed 5 months ago by Antoine Martin

Is it possible to generate a x64 windows beta build?

Not for the next few days.
In any case, you need an updated beta build of the server, you can use any recent version of the client with it.

Plink crashes with MSVCP140.dll error @ Windows 10 x64 laptop

A new build is unlikely to fix this. Does this occur with older versions or just the 2.3 beta?

Last edited 5 months ago by Antoine Martin (previous) (diff)

comment:4 Changed 5 months ago by stdedos

The installed 2.2.4 x64 does not. Installing today Xpra_Setup_2.3-r19007.exe gave this issue.

In any case, you need an updated beta build of the server, you can use any recent version of the client with it.

Define "any recent". 2.2.4 r18312 works?

Also, is it possible that "C:\Program Files\Xpra\xpra" --version - or whichever combination is allowed - to show the version on the command line of Windows as well? Can you take it from here, or should I create a new ticket?

comment:5 Changed 5 months ago by Antoine Martin

The installed 2.2.4 x64 does not.

Does not what?

Installing today Xpra_Setup_2.3-r19007.exe gave this issue.

What issue? See comment:1 for the debugging information requested with newer builds.

Define "any recent". 2.2.4 r18312 works?

Yes. For the client, any 2.x build should work, or even 1.x.
Since you are using 2.2.x, make sure to use the latest version from that branch, which is 2.2.6 as of now.

Also, is it possible that "C:\Program Files\Xpra\xpra" --version - or whichever combination is allowed - to show the version on the command line of Windows as well?

Use Xpra_cmd.exe for command line output, Xpra.exe is for GUI usage only.

comment:6 in reply to:  5 Changed 5 months ago by stdedos

Replying to Antoine Martin:

The installed 2.2.4 x64 does not.

Does not what?

The installed 2.2.4 x64 does not crash, show that error or otherwise malfunction.

Installing today Xpra_Setup_2.3-r19007.exe gave this issue.

What issue? See comment:1 for the debugging information requested with newer builds.

Plink crashes with MSVCP140.dll error @ Windows 10 x64 laptop


Define "any recent". 2.2.4 r18312 works?

Yes. For the client, any 2.x build should work, or even 1.x.
Since you are using 2.2.x, make sure to use the latest version from that branch, which is 2.2.6 as of now.

I will update the stable and inform you on Monday about the results. (Plink or #1806 or #1801 output)

Changed 5 months ago by stdedos

Attachment: xpra-log.log added

comment:7 Changed 5 months ago by stdedos

Owner: changed from stdedos to Antoine Martin

I am not sure where to post the results. I'll continue here.

Plink works (as I already said) on 2.2.+

While --start works, shadow cannot :/

Awaiting debugging instructions

comment:8 Changed 5 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

From the log file:

C:\>"C:\Program Files\Xpra\xpra_cmd" shadow ssh:user@SERVERIP

So you're starting a remote shadow without specifying the display to shadow, this may fail if there is more than one display active, which may be the case if you have started other xpra sessions for example.

Try starting the shadow server in advance, which will give you a log file you can inspect (directly on the server):

xpra shadow :THEDISPLAY

or specify the display to shadow (from the client):

xpra_cmd.exe shadow ssh://user@SERVERIP/THESERVERDISPLAY

I am getting confused by this ticket now, because this has little to do with 3 monitors?

Last edited 5 months ago by Antoine Martin (previous) (diff)

comment:9 Changed 5 months ago by stdedos

I am not sure where to post the results. I'll continue here.

I wasn't sure where you wanted me to report this. You asked me to run the beta server on this ticket, I reported on this one. :/

We can move it to any other place of your choice :-)

So you're starting a remote shadow without specifying the display to shadow, this may fail if there is more than one display active, which may be the case if you have started other xpra sessions for example.

I never actually specified a monitor on the commandline :/

Running

C:\>"C:\Program Files\Xpra\xpra_cmd" shadow ssh:user@SERVERIP:THESERVERDISPLAY

Didn't change anything.

Running

C:\>"C:\Program Files\Xpra\xpra_cmd" shadow ssh://user@SERVERIP//THESERVERDISPLAY

Does not even give me a password prompt.

Try starting the shadow server in advance, which will give you a log file you can inspect (directly on the server):

Follow output on the new attachment. I also have the -d includes, if they help at all.

Last edited 5 months ago by Antoine Martin (previous) (diff)

Changed 5 months ago by stdedos

Attachment: xpra-log-2.log added

comment:10 Changed 5 months ago by Antoine Martin

From your log output:

makeRootWindowModels()=[GTKX11RootWindowModel(0x29f - (0, 30, 1680, 1050)), GTKX11RootWindowModel(0x29f - (1680, 0, 1920, 1080)), GTKX11RootWindowModel(0x29f - (3600, 0, 1920, 1080))]

So the 3 monitors are detected just fine. The client should show them as 3 separate windows.

Note: if you started your server with "xpra shadow", you should "xpra attach" from the client - no need to ask it to start a new shadow.

Changed 5 months ago by stdedos

Attachment: xpra-attach.log added

comment:11 Changed 5 months ago by stdedos

I mistakenly attached from local computer. Suprisingly, it worked correctly. (on the attached log)

No combination of

attach ssh://user@SERVERIP
attach ssh://user@SERVERIP//THESERVERDISPLAY

worked (on the attached log)

comment:12 Changed 5 months ago by Antoine Martin

Failures to attach are unrelated to this ticket, so please file a separate ticket for that. Looking at your log, I've already found:

  • a minor harmless bug, fixed in r19020
  • Warning: more than 30 clipboard requests per second! - you have a clipboard loop, you should disable the clipboard if it doesn't get disabled automatically
  • this warning is usually a sign that things are very bad indeed, could be related to the clipboard:
    Warning: delayed region timeout
    region is 15 seconds old, will retry - bad connection?
    

Changed 5 months ago by stdedos

Attachment: xpra-logs.tar.bz2 added

comment:13 Changed 5 months ago by stdedos

Owner: changed from stdedos to Antoine Martin

I tried to replicate this after I fixed my command line. (#1813)

Screens seem to attach correctly (both for active monitors and on standby).

However, as I scaled them down, I saw (see attachment). Only the image is scaled down, otherwise I need to click on the "correct" window place to actually click where I am targeting.

I am not sure if this is fixed with the #1801 or the scaling issue is "still the same bug".

I only managed to see it once, and I cannot replicate it anymore.
Invocation was xpra shadow, so no -d shadow,geometry debug logs. :/

Handle it to your best judgement.

Changed 5 months ago by stdedos

Attachment: xpra-shadow-win10.tar.bz2 added

comment:14 Changed 5 months ago by Antoine Martin

Resolution: invalid
Status: newclosed

Screens seem to attach correctly (both for active monitors and on standby).

I am closing as "invalid" because there were no code changes related to multi-monitor handling since #1801.

Only the image is scaled down, otherwise I need to click on the "correct" window place to actually click where I am targeting.
I am not sure if this is fixed with the #1801 or the scaling issue is "still the same bug".
I only managed to see it once, and I cannot replicate it anymore.

This is likely to be fixed by r19018: #1811.
If you can still reproduce the problem, please provide steps to reproduce in that ticket.

Last edited 5 months ago by Antoine Martin (previous) (diff)
Note: See TracTickets for help on using tickets.