xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

#1807 closed defect (fixed)

undefined function get_util_logger

Reported by: Alfred Owned by: Antoine Martin
Priority: minor Milestone:
Component: core Version: 1.0.x
Keywords: Cc:

Description

After upgrading from xpra version 1.0.10-r18414-1 to 1.0.11-r19007-1, I found that there seems to be an undefined function, get_util_logger, at line 269 in file /usr/lib/python2.7/dist-packages/xpra/os_util.py .

def load_binary_file(filename):
    if not os.path.exists(filename):
        return None
    try:
        with open(filename, "rb") as f:
            return f.read()
    except Exception as e:
        get_util_logger().warn("Warning: failed to load '%s':", filename)
        get_util_logger().warn(" %s", e)
        return None

Details: The host is running Ubuntu-14.04 Linux, 64-bit

Change History (1)

comment:1 Changed 3 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks for reporting this bug. It was caused by r18948 and is fixed in r19014.
This will be included in the next stable release.

This error should only occur when the filename specified exists but cannot be read - which should be quite rare. (and also why I didn't hit it when I tested)

Note: See TracTickets for help on using tickets.