xpra icon
Bug tracker and wiki

Opened 2 months ago

Closed 2 weeks ago

#1814 closed defect (worksforme)

Cannot cleanly shutdown xpra windows client

Reported by: stdedos Owned by: stdedos
Priority: minor Milestone: 2.4
Component: client Version: 2.2.x
Keywords: Cc:

Description

On Windows 10, I ran

C:\>"C:\Program Files\Xpra\xpra_cmd" shadow ssh://sntentos@172.16.57.108/0

After successfully connecting, I cannot cleanly shutdown it with Ctrl+C.

I need to close the hosting terminal

Attachments (2)

xpra-client-log_14-00.log (4.3 KB) - added by stdedos 2 months ago.
xpra-server-client-log_14-00.log (22.8 KB) - added by stdedos 2 months ago.

Download all attachments as: .zip

Change History (9)

Changed 2 months ago by stdedos

Attachment: xpra-client-log_14-00.log added

Changed 2 months ago by stdedos

comment:1 Changed 2 months ago by stdedos

Xpra gtk2 client version 2.2.6-r18959 64-bit/Windows10 and
xpra v2.3-r19012 (64 bit missing?) Ubuntu 16.04.3 x64 server

comment:2 Changed 2 months ago by Antoine Martin

Status: newassigned

I think I am seeing a hang doing this, caused by the clipboard loop (which we should detect: #1312).
When this happens, both client and server end up stuck in the main loop..
FYI: control-C usually works, but the recommended way to exit is through the system tray menu.

If you cannot reproduce this bug with --clipboard=no, then please close it and we'll follow up in #1312.

Last edited 2 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 2 months ago by stdedos

Will try it next time, see how it goes. :-)

comment:4 Changed 8 weeks ago by stdedos

Owner: changed from Antoine Martin to stdedos
Status: assignednew

comment:5 Changed 3 weeks ago by Antoine Martin

Milestone: 2.4

Can I close this?

comment:6 Changed 3 weeks ago by stdedos

Recently, I have trouble replicating that at all.

I cannot start xpra only with xpra shadow. I need to follow that up with xpra attach in order to connect.

Furthermore, I cannot replicate this neither with clipboard=yes, nor with clipboard=no (while doing "C:\Program Files\Xpra\xpra_cmd" attach ssh://sntentos@172.16.57.108/0)

If it makes any difference, I start with --opengl=no (because of greylisting) −−desktop−scaling=0.75 (since shadowed screens are bigger than my laptop's

comment:7 Changed 2 weeks ago by Antoine Martin

Resolution: worksforme
Status: newclosed

Feel free to re-open if you can provide steps to reproduce.

Note: See TracTickets for help on using tickets.