xpra icon
Bug tracker and wiki

#1815 closed defect (invalid)

Doing `shadow` on top of an existing `shadow` confuses client?

Reported by: stdedos Owned by: stdedos
Priority: major Milestone: 2.3
Component: server Version: 2.2.x
Keywords: Cc:

Description (last modified by Antoine Martin)

I am not sure how much of a "bug" this is. But I am trying to split instead of bundling up.

Xpra gtk2 client version 2.2.6-r18959 64-bit/Windows10 and
xpra v2.3-r19012 (64 bit missing?) Ubuntu 16.04.3 x64 server

On the client, I execute:
shadow ssh://sntentos@ip/0

After successfully connecting, I disconnect fiercely (see #1814)

Re-executing:
shadow ssh://sntentos@ip/0

Gives:

C:\>"C:\Program Files\Xpra\xpra_cmd" shadow ssh://sntentos@172.16.57.108/0
2018-04-20 11:19:23,001 Xpra gtk2 client version 2.2.6-r18959 64-bit
2018-04-20 11:19:23,017  running on Microsoft Windows 10
2018-04-20 11:19:24,048 GStreamer version 1.12.4 for Python 2.7.14 64-bit
2018-04-20 11:19:24,282 OpenGL_accelerate module loaded
2018-04-20 11:19:24,361 Using accelerated ArrayDatatype
2018-04-20 11:19:25,236 Warning: vendor 'Intel' is greylisted,
2018-04-20 11:19:25,236  you may want to turn off OpenGL if you encounter bugs
2018-04-20 11:19:33,892 OpenGL enabled with Intel(R) HD Graphics 4000
2018-04-20 11:19:34,064  keyboard settings: layout=us
2018-04-20 11:19:34,064  desktop size is 1600x900 with 1 screen:
2018-04-20 11:19:34,064   2\WinSta-Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2018-04-20 11:19:34,064     DISPLAY1 (310x174 mm - DPI: 131x131)
2018-04-20 11:19:34,111 keyboard layouts: us,gr
2018-04-20 11:19:34,220 Error: failed to receive anything, not an xpra server?
2018-04-20 11:19:34,236   could also be the wrong protocol, username, password or port
2018-04-20 11:19:34,236 Connection lost

on the client, and the server (see attachment)

Attachments (1)

xpra-server-client-log_dupl-shadow.log (26.0 KB) - added by stdedos 19 months ago.

Download all attachments as: .zip

Change History (3)

Changed 19 months ago by stdedos

comment:1 Changed 19 months ago by Antoine Martin

Description: modified (diff)
Milestone: 2.3
Owner: changed from Antoine Martin to stdedos

Does the first shadow session you launch work correctly? Can you interact with it?

Can you reproduce with --clipboard=no added to the command line?
If not, which clipboard synchronization tool is causing the problem?
I can't reproduce with the clipboard disabled, so this looks like a problem that #1312 should solve.

comment:2 Changed 19 months ago by stdedos

Resolution: invalid
Status: newclosed

I think you are right - clipboard sync does affect this :/

Note: See TracTickets for help on using tickets.