xpra icon
Bug tracker and wiki

Opened 2 months ago

Closed 4 weeks ago

#1849 closed enhancement (invalid)

launcher icons not shown collected on taskbar

Reported by: Tom Söderlund Owned by: Antoine Martin
Priority: trivial Milestone: 2.4
Component: client Version: 2.3.x
Keywords: launcher, icon, taskbar Cc:

Description

Active Xpra Launcher session icons are shown separately on Windows 10 taskbar even when the taskbar becomes full. They could be shown collected together to save space, like normally happens when running multiple instances of the same program. Perhaps something in Launcher is preventing this from happening.

Attachments (1)

xpra-taskbar.PNG (6.8 KB) - added by Tom Söderlund 2 months ago.
screnshot of the crowded taskbar

Download all attachments as: .zip

Change History (3)

Changed 2 months ago by Tom Söderlund

Attachment: xpra-taskbar.PNG added

screnshot of the crowded taskbar

comment:1 Changed 2 months ago by Antoine Martin

Milestone: 2.4
Status: newassigned

comment:2 Changed 4 weeks ago by Antoine Martin

Resolution: invalid
Status: assignedclosed

This is working as intended, see #799 for details.
You can turn off this behaviour with the environment variable XPRA_WIN32_GROUP_LEADER=0.
But then all the windows will be grouped under the same xpra taskbar entry, no matter how many xpra connections you have or how many applications run on the server side for each connection.

Related links: SetCurrentProcessExplicitAppUserModelID, see Application User Model IDs (AppUserModelIDs) and Taskbar Extensions.
Note: we now set our own app id as of r19715.

Note: See TracTickets for help on using tickets.