xpra icon
Bug tracker and wiki

#1852 closed defect (fixed)

windows fail to render content with python 2.6

Reported by: Wes Harrell Owned by: Antoine Martin
Priority: major Milestone: 2.4
Component: client Version: 1.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

OS: Centos 6.9
Xpra: 1.0.11-2

After updating to 1.0.11-2 from 1.0.10-1 windows no longer render content. The window frame is drawn but nothing appears within the window. We get a traceback that displays:

2018-05-22 16:21:30,423 Error painting rgb24
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/xpra/client/window_backing_base.py", line 288, in do_paint_rgb
    success = paint_fn(img_data, x, y, width, height, rowstride, options)
  File "/usr/lib64/python2.6/site-packages/xpra/client/gtk2/pixmap_backing.py", line 130, in _do_paint_rgb24
    if isinstance(img_data, (memoryview, _buffer, bytearray)):
NameError: global name 'memoryview' is not defined

If we remove the following line from pixmap_backing.py, it works:

        if isinstance(img_data, (memoryview, _buffer, bytearray)):

Attachments (1)

xpra-1.0.11-2.r19015.zip (441.8 KB) - added by Wes Harrell 14 months ago.
Bug Report output

Download all attachments as: .zip

Change History (2)

Changed 14 months ago by Wes Harrell

Attachment: xpra-1.0.11-2.r19015.zip added

Bug Report output

comment:1 Changed 14 months ago by Antoine Martin

Component: androidclient
Description: modified (diff)
Milestone: 2.4
Resolution: fixed
Status: newclosed
Summary: Window fails to render contentwindows fail to render content with python 2.6

Note: this only triggers with the non-opengl rendering codepath when running under python 2.6 (ie: centos6).

This was caused by r18768 and is fixed in r18946.
This will be included in 1.0.12.

Note: See TracTickets for help on using tickets.