xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 4 months ago

Last modified 4 months ago

#1859 closed defect (fixed)

--use-display: XAUTHORITY is not honoured

Reported by: mviereck Owned by: Antoine Martin
Priority: critical Milestone: 2.4
Component: server Version: 2.3.x
Keywords: Cc:

Description

System: debian 9, winswitch repository

Since xpra v2.3-r19246 xpra does not use/regard XAUTHORITY to access a display with --use-display if the specified display uses cookie authentication. It fails with 'no protocol specified'.

Code to reproduce:

/usr/bin/Xvfb :40 -screen 0 1920x1080x24 \
  -nolisten tcp -dpms -s off -retro \
  +extension Composite +extension RANDR +extension RENDER +extension GLX\
  +extension XTEST \
  -auth /tmp/cookie \
  &

sleep 2
xauth -f /tmp/cookie add :40 . $(mcookie)
# env DISPLAY=:40 XAUTHORITY=/tmp/cookie xterm   #no error message
env DISPLAY=:40 XAUTHORITY=/tmp/cookie xpra start :40 --use-display  --start-via-proxy=no --daemon=no

Change History (3)

comment:1 Changed 5 months ago by Antoine Martin

Milestone: 2.4
Priority: majorcritical
Status: newassigned

comment:2 Changed 4 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

This was caused by r18646 and #1776.

Fixed in r19606. This will be included in the next stable update. Thanks for the report.

comment:3 Changed 4 months ago by Antoine Martin

Summary: --use-display: XAUTHORITY is not regarded--use-display: XAUTHORITY is not honoured
Note: See TracTickets for help on using tickets.