xpra icon
Bug tracker and wiki

Opened 2 months ago

Closed 2 months ago

#1866 closed defect (fixed)

xpra Package broken in winswitch repo for fedora27

Reported by: Sebastian Owned by: Sebastian
Priority: major Milestone: 2.4
Component: packaging Version: 2.3.x
Keywords: Cc: sebastian_himmler@…

Description

Hi,

it's not possible anymore to update xpra in due to wrong dependencies. Fedora hast libx264 version 148 in repos. xpra requires 152.

Last metadata expiration check: 0:03:12 ago on Wed Jun  6 11:07:55 2018.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package python2-xpra-2.2.6-1.r18970.fc27.x86_64
  - nothing provides libx264.so.152()(64bit) needed by python2-xpra-2.3.1-1.r19533.fc27.x86_64
 Problem 2: package python2-xpra-server-2.3.1-1.r19533.fc27.x86_64 requires python2-xpra = 2.3.1-1.r19533.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package python2-xpra-server-2.2.6-1.r18970.fc27.x86_64
  - nothing provides libx264.so.152()(64bit) needed by python2-xpra-2.3.1-1.r19533.fc27.x86_64
 Problem 3: package python2-xpra-client-2.3.1-1.r19533.fc27.x86_64 requires python2-xpra = 2.3.1-1.r19533.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package python2-xpra-client-2.2.6-1.r18970.fc27.x86_64
  - nothing provides libx264.so.152()(64bit) needed by python2-xpra-2.3.1-1.r19533.fc27.x86_64
 Problem 4: package python2-xpra-audio-2.3.1-1.r19533.fc27.x86_64 requires python2-xpra = 2.3.1-1.r19533.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package python2-xpra-audio-2.2.6-1.r18970.fc27.x86_64
  - nothing provides libx264.so.152()(64bit) needed by python2-xpra-2.3.1-1.r19533.fc27.x86_64
 Problem 5: package xpra-2.3.1-1.r19533.fc27.x86_64 requires python2-xpra-audio = 2.3.1-1.r19533.fc27, but none of the providers can be installed
  - package python2-xpra-audio-2.3.1-1.r19533.fc27.x86_64 requires python2-xpra = 2.3.1-1.r19533.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package xpra-2.2.6-1.r18970.fc27.x86_64
  - nothing provides libx264.so.152()(64bit) needed by python2-xpra-2.3.1-1.r19533.fc27.x86_64
 Problem 6: package python2-xpra-2.2.6-1.r18970.fc27.x86_64 requires xpra-common = 2.2.6-1.r18970.fc27, but none of the providers can be installed
  - cannot install both xpra-common-2.3.1-1.r19533.fc27.noarch and xpra-common-2.2.6-1.r18970.fc27.noarch
  - problem with installed package python2-xpra-2.2.6-1.r18970.fc27.x86_64
  - cannot install the best update candidate for package xpra-common-2.2.6-1.r18970.fc27.noarch
  - nothing provides libx264.so.152()(64bit) needed by python2-xpra-2.3.1-1.r19533.fc27.x86_64
 Problem 7: package python2-xpra-client-2.2.6-1.r18970.fc27.x86_64 requires xpra-common-client = 2.2.6-1.r18970.fc27, but none of the providers can be installed
  - problem with installed package python2-xpra-client-2.2.6-1.r18970.fc27.x86_64
  - cannot install both xpra-common-client-2.3.1-1.r19533.fc27.noarch and xpra-common-client-2.2.6-1.r18970.fc27.noarch
  - package python2-xpra-client-2.3.1-1.r19533.fc27.x86_64 requires python2-xpra = 2.3.1-1.r19533.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package xpra-common-client-2.2.6-1.r18970.fc27.noarch
  - nothing provides libx264.so.152()(64bit) needed by python2-xpra-2.3.1-1.r19533.fc27.x86_64
 Problem 8: package python2-xpra-server-2.2.6-1.r18970.fc27.x86_64 requires xpra-common-server = 2.2.6-1.r18970.fc27, but none of the providers can be installed
  - problem with installed package python2-xpra-server-2.2.6-1.r18970.fc27.x86_64
  - cannot install both xpra-common-server-2.3.1-1.r19533.fc27.noarch and xpra-common-server-2.2.6-1.r18970.fc27.noarch
  - package python2-xpra-server-2.3.1-1.r19533.fc27.x86_64 requires python2-xpra = 2.3.1-1.r19533.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package xpra-common-server-2.2.6-1.r18970.fc27.noarch
  - nothing provides libx264.so.152()(64bit) needed by python2-xpra-2.3.1-1.r19533.fc27.x86_64
================================================================================================================================================================
 Package                                     Arch                           Version                                     Repository                         Size
================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 xpra-common                                 noarch                         2.3.1-1.r19533.fc27                         winswitch                         318 k
 xpra-common-client                          noarch                         2.3.1-1.r19533.fc27                         winswitch                          72 k
 xpra-common-server                          noarch                         2.3.1-1.r19533.fc27                         winswitch                         111 k
Skipping packages with broken dependencies:
 python2-xpra                                x86_64                         2.3.1-1.r19533.fc27                         winswitch                         2.4 M
 python2-xpra-audio                          x86_64                         2.3.1-1.r19533.fc27                         winswitch                         135 k
 python2-xpra-client                         x86_64                         2.3.1-1.r19533.fc27                         winswitch                         522 k
 python2-xpra-server                         x86_64                         2.3.1-1.r19533.fc27                         winswitch                         690 k
 xpra                                        x86_64                         2.3.1-1.r19533.fc27                         winswitch                          69 k

Transaction Summary
================================================================================================================================================================
Skip  8 Packages

Nothing to do.
Complete!

Change History (3)

comment:1 Changed 2 months ago by Sebastian

Cc: sebastian_himmler@… added

comment:2 Changed 2 months ago by Antoine Martin

Milestone: 2.4
Owner: changed from Antoine Martin to Sebastian

Sorry about that. The updated x264-xpra package was in the beta repo but missing from the stable one, that's now fixed.
Please try to update again. I've just done a clean install on F27 and that worked fine.

comment:3 Changed 2 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Got this via email:

this is also broken for fedora 26. Can you update this repo, too?

No, sorry. Fedora 26 is EOL.

Note: See TracTickets for help on using tickets.