xpra icon
Bug tracker and wiki

Opened 2 weeks ago

Closed 13 days ago

#1868 closed defect (fixed)

decoding errors: "invalid data"

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: critical Milestone: 2.4
Component: encodings Version: trunk
Keywords: Cc:

Description

Discovered whilst testing #1867 at 4k unscaled, using:

mplayer -fs -zoom somevideo.flv

With vp9 (auto):

2018-06-09 11:34:11,831 client @05.512 Error: avcodec error -1094995529 decoding 48331 bytes of vp9 data:
2018-06-09 11:34:11,831 client @05.512  'Invalid data found when processing input'
2018-06-09 11:34:11,831 client @05.513  frame 0
2018-06-09 11:34:11,831 client @05.513  frame options:
2018-06-09 11:34:11,831 client @05.513                   frame = 2
2018-06-09 11:34:11,832 client @05.513                     csc = YUV420P
2018-06-09 11:34:11,832 client @05.513                encoding = vp9
2018-06-09 11:34:11,832 client @05.513  decoder state:
2018-06-09 11:34:11,832 client @05.513          decoder_height = 2160
2018-06-09 11:34:11,832 client @05.514                encoding = vp9
2018-06-09 11:34:11,832 client @05.514              colorspace = YUV420P
2018-06-09 11:34:11,832 client @05.514       actual_colorspace = YUV420P
2018-06-09 11:34:11,832 client @05.514                  height = 2160
2018-06-09 11:34:11,832 client @05.514           decoder_width = 3840
2018-06-09 11:34:11,833 client @05.514                   width = 3840
2018-06-09 11:34:11,833 client @05.515                 version = 58, 18, 100
2018-06-09 11:34:11,833 client @05.515                 formats = YUV420P, YUV444P
2018-06-09 11:34:11,861 client @05.515                  frames = 0
2018-06-09 11:34:11,862 client @05.515                    type = avcodec

But also with h264 (--video-encoders=x264):

2018-06-09 11:36:44,113 client @07.794 Error: avcodec error -1094995529 decoding 176887 bytes of h264 data:
2018-06-09 11:36:44,134 client @07.794  'Invalid data found when processing input'
2018-06-09 11:36:44,134 client @07.795  frame 0
2018-06-09 11:36:44,153 client @07.795  frame options:
2018-06-09 11:36:44,154 client @07.795                    type = P
2018-06-09 11:36:44,154 client @07.795                   frame = 1
2018-06-09 11:36:44,154 client @07.796                     pts = 195
2018-06-09 11:36:44,154 client @07.796                     csc = YUV420P
2018-06-09 11:36:44,155 client @07.796                encoding = h264
2018-06-09 11:36:44,155 client @07.796  decoder state:
2018-06-09 11:36:44,155 client @07.796          decoder_height = 2160
2018-06-09 11:36:44,155 client @07.796                encoding = h264
2018-06-09 11:36:44,155 client @07.796              colorspace = YUV420P
2018-06-09 11:36:44,155 client @07.796       actual_colorspace = YUV420P
2018-06-09 11:36:44,155 client @07.796                  height = 2160
2018-06-09 11:36:44,155 client @07.797           decoder_width = 3840
2018-06-09 11:36:44,155 client @07.797                   width = 3840
2018-06-09 11:36:44,155 client @07.797                 version = 58, 18, 100
2018-06-09 11:36:44,155 client @07.797                 formats = GBRP, RGB, YUV420P, BGRA, BGRX, ARGB, YUV422P, XRGB, YUV444P
2018-06-09 11:36:44,155 client @07.797                  frames = 0
2018-06-09 11:36:44,155 client @07.797                    type = avcodec

Change History (2)

comment:1 Changed 2 weeks ago by Antoine Martin

Status: newassigned
Version: 2.3.xtrunk

Also happens with the vpx decoder: --video-decoders=vpx rather than avcodec2.

comment:2 Changed 13 days ago by Antoine Martin

Resolution: fixed
Status: assignedclosed
Summary: decoding errors at 4kdecoding errors: "invalid data"

Caused by #1850, fixed in 19592.

Only send eos if this video encoder is still current, otherwise, sending the new stream will have taken care of it already, and sending eos then would close the new stream, not the old one!

Note: See TracTickets for help on using tickets.