xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 weeks ago

#1907 closed defect (fixed)

Xpra does not react

Reported by: michael Owned by: michael
Priority: minor Milestone: 2.4
Component: client Version: 2.3.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Sometimes the actions via "Information" e.g. "Bug Report" & "About Window") "Server"->"Run Command" or "Windows"->"Minimize Windows" do nothing.

If i activate another program, all works fine again.

A similar problem can occur: The xpra-window is active and nothing happens if i type. I must switch the task and switch back again and all is fine.

Xpra 2.3.1 64 Bit Client (2.3.1 revision 19531) + Server (2.3.1-r19533-1)
Win7 (VDI) -> Ubuntu 16.04 (virtual)
independent of Desktop Environment (simple terminator and lxde-desktop, too)
LAN (no limit)
e.g. "C:\Program Files\Xpra\Xpra.exe" start --start-child=terminator ssh:user@fqdn:1000 --encoding=png −−pulseaudio=no −−speaker=no −−microphone=no --keyboard-layout=de
Not sure if older versions have this problem.
More users have the problem - others use it too rarely.

Attachments (2)

Xpra.log (264.2 KB) - added by michael 2 months ago.
Xpra.zip (266.8 KB) - added by michael 2 months ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 3 months ago by Antoine Martin

Description: modified (diff)
Milestone: 2.4
Owner: changed from Antoine Martin to michael

Sometimes...

How reproducible is it?
Can you run the client with "-d all" and capture the output when this occurs?

You may want to try the GTK3 / Python3 builds from https://xpra.org/beta/windows to see if those work better for you.

BTW, encoding=png is usually a bad idea, try --quality=100 instead. (and FYI: start-child=xyz without exit-with-children is pointless, might as well use start=xyz)

comment:2 Changed 3 months ago by michael

Hmmmm -d all: xpra starts but the terminator windows doesn't appear in 10 minutes. The logfile is ~700kb. I stopped the process - it must be useable.

Could you tell which alternatives to "all" (wiki/Logging/Categories) would be fine for you, please?

Last edited 3 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 3 months ago by michael

Owner: changed from michael to Antoine Martin

comment:4 Changed 3 months ago by michael

Is it a problem if i comment an issue and submit changes and reassign it afterwards in a second submit? Sorry - i forgot it in the first step.

comment:5 Changed 3 months ago by michael

encoding=png is usually a bad idea, try --quality=100 instead

Thanks - i tried to compare it: speed and font readability seems to be equal. Why is png a bad idea? Data volume?

FYI: start-child=xyz without exit-with-children is pointless, might as well use start=xyz

I tried it but --start=xyz: Systray icon appears and disappears after 1 second.
Anyway i append --exit-with-children :-).

But all examples use --start-child without --exit-with-children: wiki/Usage - and yes, there is a notice but ...

Last edited 3 months ago by Antoine Martin (previous) (diff)

comment:6 Changed 3 months ago by Antoine Martin

Owner: changed from Antoine Martin to michael

Is it a problem if i comment an issue and submit changes and reassign it afterwards in a second submit? Sorry - i forgot it in the first step.

No problem.

Thanks - i tried to compare it: speed and font readability seems to be equal. Why is png a bad idea? Data volume?

xpra will be able to chose a better encoding where appropriate, webp and plain rgb are more efficient in many cases. PNG is very CPU intensive, which adds latency.

I tried it but --start=xyz: Systray icon appears and disappears after 1 second.

This should not make any difference whatsoever.

But all examples use --start-child without --exit-with-children ...

Good catch! (fixed)

Hmmmm -d all: xpra starts but the terminator windows doesn't appear in 10 minutes...
Could you tell which alternatives to "all"

Not sure since I don't know where the problem is.
At least: -d client,info,clipboard,screen,menu,events,focus,mouse,cursor,gtk,util,win32.
Good luck!

Changed 2 months ago by michael

Attachment: Xpra.log added

comment:7 Changed 2 months ago by michael

Owner: changed from michael to Antoine Martin

util does not work - terminator does not appear. I used -d client,info,clipboard,screen,menu,events,focus,mouse,cursor,gtk,win32.

Started Xpra, moved Terminator window to second screen, maximized window.
Now right mouse click on Xpra systray icon -> Information -> About Xpra.
No window appeared. Minimized Terminator window to check if the about window appeard in background of it - nothing.
Uploaded Xpra.log

comment:8 Changed 2 months ago by Antoine Martin

Owner: changed from Antoine Martin to michael

util does not work - terminator does not appear.

If that's the case then there should be an error message somewhere caused by "util" debug logging. Maybe this will give us a clue. Try turning on just "-d util" debug logging to trigger it.

And maybe also try the beta builds (same caveat as #1908: don't use remote ssh start, just use ssh attach)

(the error caused by "util" may well be in the server log - another reason for starting and attaching with separate commands when debugging)

Now right mouse click on Xpra systray icon -> Information -> About Xpra.

Does it make any difference if you use a left click instead? (not sure that does anything on win32 - I don't have a VM with me to use for testing right now)
The systray mouse handling is a bit finicky - each platform does things differently, and we do have some workarounds for win32 already..
Be aware that you may want, or have to, release the mouse button before hovering over the tray menus. For some strange reason, this can make a difference on some platforms.

comment:9 Changed 2 months ago by michael

I tested with newest Windows Beta to reproduce the icon problem (#1908) and did a quick check if the about window appears. 2* in a row with the right mouse button: no window. Then i tested it with the left mouse button und the window appeared.

comment:10 Changed 2 months ago by Antoine Martin

Owner: changed from michael to Antoine Martin
Status: newassigned

with the right mouse button: no window. Then i tested it with the left mouse button and the window appeared.

OK, I will try to find a workaround for this - but this looks like a GTK problem. The python3 builds (which use GTK3) may fare better.

Changed 2 months ago by michael

Attachment: Xpra.zip added

comment:11 Changed 2 months ago by michael

Owner: changed from Antoine Martin to Antoine Martin
Status: assignednew

Yesterday i tested several debug-settings (server side and client side).
As a result i had -d tray,icon on the server side and -d client,info,clipboard,screen,menu,events,focus,mouse,cursor,gtk,util,win32 on the client side :-). I hope this is not a problem for this systray incident.
Btw: -d util works when i use it at at client side (attach).
Today the problem appeared again (right mouse button: several times it did not appear and after a few tests it appeared) and i have a 23 MB logfile on the client.
I truncated it to all events since i arrived today in the company. I hope this is fine. See Xpra.zip
I will try to reproduce the problem with the left mouse button only.

comment:12 Changed 2 months ago by michael

Until now: Works with the left mouse button. I will try it from time to time and add an info here.

comment:13 Changed 2 months ago by michael

The problem did not occur with the left mouse button until now.

Anyway - i have two monitors and sometimes a similar problem arises: After activating the my Xpra-window it does not react. I must switch back (alt-tab) and forth (alt-tab) and then Xpra reacts again. Should i open a new issue for that?

comment:14 Changed 5 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

I can reproduce.
The problem seems identical to #724 and r8064 is meant to fix this. (improved in r9002)

comment:15 Changed 5 weeks ago by Antoine Martin

Priority: majorminor

The Python3 / GTK3 version of the client is not affected, so lowering the priority.

The workaround class isn't used as much as it should be, and in some cases we need to add the fix to other menu item classes (ie: gtk.ImageMenuItem)

Last edited 5 weeks ago by Antoine Martin (previous) (diff)

comment:16 Changed 5 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to michael
Status: assignednew

Fixed:

  • r20127 ensure the fix from r8064 is used with GTK2 (don't use the unpatched GTK class directly)
  • r20128 debugging and error handling improvements
  • r20129 add tray workaround code for image menu items

Backported to v2.3 in r20130.

@michael: new beta builds posted: https://xpra.org/beta/windows - please close if that works for you.

comment:17 Changed 3 weeks ago by Antoine Martin

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.