xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 2 weeks ago

Last modified 2 weeks ago

#1908 closed defect (fixed)

Xpra icon changes

Reported by: michael Owned by: michael
Priority: major Milestone: 2.4
Component: client Version: 2.3.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Icon of Xpra in taskbar (Win7) sometimes changes during use to the symbol of other applications (Outlook, Firefox, ...) - confusing

Xpra 2.3.1 64 Bit Client (2.3.1 revision 19531) + Server (2.3.1-r19533-1)
Win7 (VDI) -> Ubuntu 16.04 (virtual)
independent of Desktop Environment (simple terminator and lxde-desktop, too)
LAN (no limit)
e.g. C:\Program Files\Xpra\Xpra.exe" start --start-child=terminator ssh:user@fqdn:1000 --encoding=png −−pulseaudio=no −−speaker=no −−microphone=no --keyboard-layout=de
Same problem with 0.16 which i used before.
More users have the problem - others use it too rarely.

Attachments (5)

xpra-outlook.png (12.0 KB) - added by michael 3 months ago.
Xpra.log (373.5 KB) - added by michael 3 months ago.
Beta24_xpra_main_error.png (10.8 KB) - added by michael 2 months ago.
Xpra2.log (154.6 KB) - added by michael 2 months ago.
2.4-r19929-tray-debug.log (67.6 KB) - added by Antoine Martin 7 weeks ago.
convert large log sample to an attachment

Download all attachments as: .zip

Change History (28)

comment:1 Changed 3 months ago by michael

Component: androidclient

comment:2 Changed 3 months ago by Antoine Martin

Description: modified (diff)
Milestone: 2.4
Owner: changed from Antoine Martin to michael

This sounds like it could be #1707, which would mean that this working as intended.
Are you talking about the taskbar or the systray?
It is meant to allow us to distinguish xpra forwarded windows from local ones. (ie: firefox local vs remote)

changes during use to the symbol of other applications (Outlook, Firefox, ...)

I doubt the icon shows the outlook icon unless you somehow managed to run outlook via xpra.

Same problem with 0.16 which i used before.

0.16 did not have this feature at all. So maybe this is / was a different problem?

Xpra 2.3.1 64 Bit Client (2.3.1 revision 19531)

Make sure you're running 2.3.2, which included a fix for this feature: r19719.

You can also disable it completely with XPRA_DYNAMIC_TRAY_ICON=0.

Changed 3 months ago by michael

Attachment: xpra-outlook.png added

comment:3 Changed 3 months ago by michael

taskbar!:

comment:4 Changed 3 months ago by michael

Owner: changed from michael to Antoine Martin

comment:5 Changed 3 months ago by Antoine Martin

Owner: changed from Antoine Martin to michael

How odd! The icon in the taskbar should be the one from the window when there is only one window.
I have no idea how we could ever get the icon for outlook or from where!

Can you reproduce this with "-d tray,icon" added to the client command line?
Does the problem go away if you run with XPRA_DYNAMIC_TRAY_ICON=0?

Changed 3 months ago by michael

Attachment: Xpra.log added

comment:6 Changed 3 months ago by michael

Owner: changed from michael to Antoine Martin

I have no idea how we could ever get the icon for outlook or from where!

Me, too :-)

Can you reproduce this with "-d tray,icon" added to the client command line?

Yes - Xpra.log appended.
Yesterday it changed to an empty icon. Today it changed to Notepad++ icon.

Does the problem go away if you run with XPRA_DYNAMIC_TRAY_ICON=0?

I will try today.

comment:7 Changed 3 months ago by Antoine Martin

Owner: changed from Antoine Martin to michael

Well, the icon part looks OK but there are a number of errors in that log file, some of which give the wrong geometry for the monitors and therefore for the system tray too.
I guess that us using the wrong dimensions for the tray icon could somehow cause MS Windows to trip over itself?

  • r19924 fixes the AssertionError in _focus_change - likely unrelated and harmless
  • r19925 fixes the OverflowError: long int too long to convert in GetMonitorInfo (+r19929 fixup)
  • r19928 improves the debug logging

Please try the latest 2.4 beta build to see if that resolves those issues (only known limitation of this build is the lack of webcam forwarding): https://xpra.org/beta/windows/.

Changed 2 months ago by michael

Attachment: Beta24_xpra_main_error.png added

comment:8 Changed 2 months ago by michael

Owner: changed from michael to Antoine Martin

Beta 2.4 (2018-07-11) does not work here - screenshot attached.

Text:

xpra main error
Traceback (most recent call last):
  File "./xpra/scripts/main.py", line 75, in main
  File "./xpra/scripts/main.py", line 286, in run_mode
  File "./xpra/scripts/ma in.py", line 1605, in run_remote_server
TypeError: init() takes exactly 2 arguments (3 given)
Last edited 2 months ago by Antoine Martin (previous) (diff)

comment:9 Changed 2 months ago by Antoine Martin

Owner: changed from Antoine Martin to michael

Beta 2.4 (2018-07-11) does not work here - screenshot attached.

Try starting the server first from an SSH session, then connect to it with:

xpra_cmd attach ssh://user@host:SSHPORT/

(FYI: this is the recommended way of debugging things, the all-in-one remote start command can hide some details - esp wrt ssh)

comment:10 Changed 2 months ago by michael

Owner: changed from michael to Antoine Martin

Excuse me for asking:

Until now i start my session during start and the debugging parameters are passed throug. If i split start and attach:
Must i activate the debug statements at start of the server process and/or at client attach?
Which logfile is relevant for you? Server (Linux) or client (Windows)?

comment:11 Changed 2 months ago by Antoine Martin

Owner: changed from Antoine Martin to michael

Must i activate the debug statements at start of the server process and/or at client attach?

When in doubt, best to do both. Some will only be relevant to one end, which is fine.

Which logfile is relevant for you? Server (Linux) or client (Windows)?

By default remote-logging=yes so the server log should include the client log output.
But in this case, I strongly suspect that this a client-only problem (where would the server get an outlook icon?!), so the client log would be enough.

Changed 2 months ago by michael

Attachment: Xpra2.log added

comment:12 Changed 2 months ago by michael

Owner: changed from michael to Antoine Martin

Beta 2.4 (2018-07-11) with attach and -d tray,icon creates the problem (Word icon) - Xpra2.log attached.

comment:13 Changed 2 months ago by michael

A question according the 2.4 Beta: Do I have to worry that the beta version will not start or is this a known problem that is still being fixed?

comment:14 Changed 2 months ago by Antoine Martin

Owner: changed from Antoine Martin to michael

A question according the 2.4 Beta: Do I have to worry that the beta version will not start or is this a known problem that is still being fixed?

I assume you mean the xpra start ssh:host syntax?
This is fixed in r19973, unfortunately it will be a few weeks before I am able to make updated MS Windows beta builds again.

Did setting XPRA_DYNAMIC_TRAY_ICON=0 help?
Can you also reproduce with the clipboard disabled? (ie: --clipboard=no)

Note to self: maybe we should cache the LoadImage result for the default icon rather than hitting the disk every time, and maybe we're also leaking HICON handles.

comment:15 Changed 8 weeks ago by michael

Problem occurs normally within 1 day. Startet the XPRA_DYNAMIC_TRAY_ICON test now.

comment:16 Changed 7 weeks ago by michael

Owner: changed from michael to Antoine Martin

It seemed that the problem doesn't occur so often with XPRA_DYNAMIC_TRAY_ICON=0 but today i have the issue again. I can surprisingly change the icon:
Open a note from Outlook -> symbol changes to the note symbol or to the Outlook symbol.
Close the note -> symbol changes to an empty one.
Start of any new program -> symbol changes to the started program.
This was now reproducible 20 or more times.
After start from IE the icon changed the last time - the IE icon remains...

Next test will be without clipboard. I assign the issue to you so you have this information. Feel free to reassign it back to me.

Client.log since i arrived at work:

2018-08-06 08:07:41,831 sending updated screen size to server: 3840x1200 with 1 screens
2018-08-06 08:07:41,832   Default (1016x317 mm - DPI: 96x96)
2018-08-06 08:07:41,833     DISPLAY1 1920x1200 at 1920x0 (677x423 mm - DPI: 72x72) workarea: 1920x1200
2018-08-06 08:07:41,833     DISPLAY2 1920x1200 (677x423 mm - DPI: 72x72) workarea: 1920x1200
2018-08-06 08:07:41,833 screen size change: will reinit the windows
2018-08-06 08:26:20,271 sending updated screen size to server: 3840x1200 with 1 screens
2018-08-06 08:26:20,272   Default (1016x317 mm - DPI: 96x96) workarea: 1920x1200
2018-08-06 08:26:20,272     DISPLAY1 1920x1200 at 1920x0 (677x423 mm - DPI: 72x72)
2018-08-06 08:26:20,272     DISPLAY2 1920x1200 (677x423 mm - DPI: 72x72)
2018-08-06 08:26:20,273 screen size change: will reinit the windows
2018-08-06 08:26:31,416 sending updated screen size to server: 3840x1200 with 1 screens
2018-08-06 08:26:31,416   Default (1016x317 mm - DPI: 96x96)
2018-08-06 08:26:31,416     DISPLAY1 1920x1200 at 1920x0 (677x423 mm - DPI: 72x72) workarea: 1920x1160
2018-08-06 08:26:31,416     DISPLAY2 1920x1200 (677x423 mm - DPI: 72x72) workarea: 1920x1200
2018-08-06 08:26:31,417 screen size change: will reinit the windows
2018-08-06 08:26:32,886 screen size change: will reinit the windows
2018-08-06 08:26:33,218 Warning: ignoring draw packet,
2018-08-06 08:26:33,219  received for a window which is not realized yet or gone already
2018-08-06 08:27:13,510 sending updated screen size to server: 3840x1200 with 1 screens
2018-08-06 08:27:13,510   Default (1016x317 mm - DPI: 96x96) workarea: 1920x1200
2018-08-06 08:27:13,510     DISPLAY1 1920x1200 at 1920x0 (677x423 mm - DPI: 72x72)
2018-08-06 08:27:13,510     DISPLAY2 1920x1200 (677x423 mm - DPI: 72x72)
2018-08-06 08:27:13,511 screen size change: will reinit the windows
2018-08-06 08:28:18,875 sending updated screen size to server: 3840x1200 with 1 screens
2018-08-06 08:28:18,876   Default (1016x317 mm - DPI: 96x96)
2018-08-06 08:28:18,876     DISPLAY1 1920x1200 at 1920x0 (677x423 mm - DPI: 72x72) workarea: 1920x1160
2018-08-06 08:28:18,876     DISPLAY2 1920x1200 (677x423 mm - DPI: 72x72) workarea: 1920x1200
2018-08-06 08:28:18,876 screen size change: will reinit the windows
2018-08-06 08:28:46,905 unknown string message: 0xc289L / 0x52 / 0x1d5
2018-08-06 08:28:46,906 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:28:46,914 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:28:46,915 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:29:12,733 unknown string message: 0xc289L / 0x52 / 0x1d6
2018-08-06 08:29:12,734 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:30:00,560 unknown string message: 0xc289L / 0x52 / 0x1d7
2018-08-06 08:30:00,561 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:30:34,654 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:30:34,661 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:31:21,346 unknown string message: 0xc289L / 0x52 / 0x1d8
2018-08-06 08:31:21,349 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:32:05,523 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:32:05,529 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:32:25,687 unknown string message: 0xc289L / 0x52 / 0x1d9
2018-08-06 08:32:25,694 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:32:26,017 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:32:26,045 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:34:47,397 unknown string message: 0xc289L / 0x52 / 0x1da
2018-08-06 08:34:47,398 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:34:47,775 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:34:47,776 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:35:40,307 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:35:41,088 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:35:41,090 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:35:46,127 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:35:46,807 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:35:46,808 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:45:19,057 unknown string message: 0xc289L / 0x52 / 0x1db
2018-08-06 08:45:19,059 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:47:01,304 unknown string message: 0xc289L / 0x52 / 0x1dc
2018-08-06 08:47:01,304 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:47:46,101 unknown string message: 0xc289L / 0x50 / 0x0
2018-08-06 08:47:46,110 unknown string message: 0xc289L / 0x50 / 0x0

comment:17 Changed 7 weeks ago by michael

argl - forgot to set -d tray,icon

comment:18 Changed 7 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to michael

Please try beta 2.4 r20057 or later, you can find the beta builds here: https://xpra.org/beta/windows

This "fix" may just hide the symptoms of a different problem, but at least we'll know there's a leak somewhere.

comment:19 Changed 7 weeks ago by michael

Owner: changed from michael to Antoine Martin

With XPRA_DYNAMIC_TRAY_ICON=0: Empty icon again (after 12:00 - presumably at the end) - now with -d tray,icon:

I am sorry, i did not recognize you notice with the new beta 2.4.
Now i am on holiday - back in 3,5 weeks.

Last edited 7 weeks ago by Antoine Martin (previous) (diff)

Changed 7 weeks ago by Antoine Martin

Attachment: 2.4-r19929-tray-debug.log added

convert large log sample to an attachment

comment:20 Changed 5 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to michael
  • please try the latest beta
  • maybe try running the client with the clipboard disabled: the clipboard code triggers tray icon changes / refreshes - maybe that's what eventually triggers the bug
Last edited 5 weeks ago by Antoine Martin (previous) (diff)

comment:21 Changed 3 weeks ago by michael

Back from holiday - updated to revision 20265 and trying to see what happens.

comment:22 Changed 2 weeks ago by michael

Resolution: fixed
Status: newclosed

4 days usage and 3 days idle - problem is gone (without any XPRA_DYNAMIC_TRAY_ICON settings or clipboard disabling)

comment:23 Changed 2 weeks ago by Antoine Martin

Backport in r20372. This will be included in 2.3.4.

Note: See TracTickets for help on using tickets.