xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 3 weeks ago

#1947 closed defect (duplicate)

xpra stop not working properly

Reported by: ylinr Owned by: Antoine Martin
Priority: major Milestone:
Component: server Version: 2.3.x
Keywords: Cc:

Description

Xpra version:

2.3.3-r20112

System info:

LSB Version:	:core-4.1-amd64:core-4.1-ia32:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID:	CentOS
Description:	CentOS Linux release 7.4.1708 (Core) 
Release:	7.4.1708
Codename:	Core

Issue:

When I use

xpra start

Xpra will auto decide which display number to use.

After xpra session start, when I use

xpra stop :38

to terminate session (display 38 for example), it will show

xpra stop :38
server requested disconnect:
 server shutdown
 How odd... I'm not sure what's going on with xpra at :38

This info did not shows when I use xpra 1.X

When I check login shell, it seems bash which is opened by xpra is still there

sudo w -oush
aaaaa    pts/55   :35               1:08  bash

I need to add --terminate-children=yes to avoid this.

And even I add --terminate-children=yes, when I check /tmp/.X11-unix/, X38 is still there.

And when I start new xpra session and assign :38, It will fail.

I need to use --use-display to use it again.

How can I fix this?

Change History (1)

comment:1 Changed 3 weeks ago by Antoine Martin

Resolution: duplicate
Status: newclosed

Duplicate of #1943: apply r20254 or wait for the next stable update.

AFAICT: this bug is caused by an external python library, not xpra's code. This is just a workaround.

Note: See TracTickets for help on using tickets.