xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 5 weeks ago

#1976 closed defect (duplicate)

client side can't click on anything

Reported by: Thomas B. Rücker Owned by: Thomas B. Rücker
Priority: major Milestone: 2.5
Component: client Version: trunk
Keywords: Cc:

Description

tbr@nestor:~$ xpra attach tcp:172.23.0.127:14300 --dpi=96 --desktop-scaling=1
Gtk-Message: 13:38:14.647: Failed to load module "atk-bridge"
2018-10-02 13:38:15,233 Xpra gtk2 client version 2.4-r20530 64-bit
2018-10-02 13:38:15,234  running on Linux Debian testing buster
2018-10-02 13:38:17,493 GStreamer version 1.14.3 for Python 2.7.15 64-bit

(xpra:1731): GdkGLExt-WARNING **: 13:38:17.686: Window system doesn't support OpenGL.
2018-10-02 13:38:17,686 OpenGL support could not be enabled on this hardware:
2018-10-02 13:38:17,686  OpenGL is not supported
2018-10-02 13:38:18,140  keyboard settings: rules=evdev, model=pc105, layout=pl
2018-10-02 13:38:18,555  desktop size is 1920x1080 with 1 screen:
2018-10-02 13:38:18,557   :0.0 (506x285 mm - DPI: 96x96)
2018-10-02 13:38:18,557     monitor 1 (309x174 mm - DPI: 157x157)
2018-10-02 13:38:18,772 no ethtool interface speed available for wlan0
2018-10-02 13:38:19,877 Xpra OpenGL Acceleration Failure
2018-10-02 13:38:19,877 OpenGL is not supported
2018-10-02 13:38:19,896 enabled remote logging
2018-10-02 13:38:19,896 Xpra X11 server version 2.4-r20530 64-bit
2018-10-02 13:38:19,897  running on Linux Debian testing buster
2018-10-02 13:38:19,902 no ethtool interface speed available for wlan0
2018-10-02 13:38:19,903 Attached to tcp:172.23.0.127:14300
2018-10-02 13:38:19,903  (press Control-C to detach)

2018-10-02 13:38:20,013 server does not support xi input devices
2018-10-02 13:38:20,014  server uses: xtest
2018-10-02 13:38:21,389 sound output using pulseaudio device:
2018-10-02 13:38:21,389 sound output  'Built-in Audio Analog Stereo'
2018-10-02 13:38:21,919 sound output using 'opus' audio codec
2018-10-02 13:40:40,992 server is not responding, drawing spinners over the windows
2018-10-02 13:41:03,317 server is OK again
… more spinners
2018-10-03 04:48:24,897 no ethtool interface speed available for wlan0
2018-10-03 04:48:24,914 sound output stopping

Server side is 2.4-20180926r20530-1

Using 2.4-20180922r20503-1 on the client side works as expected.

Change History (5)

comment:1 Changed 5 months ago by Thomas B. Rücker

Just in case, two more logs.
2.4-20180926r20530-1 and then 2.4-20180922r20503-1

tbr@nestor:~$ xpra attach tcp:172.23.0.127:14300 --dpi=96 --desktop-scaling=1
Gtk-Message: 04:48:28.496: Failed to load module "atk-bridge"
2018-10-03 04:48:28,903 Xpra gtk2 client version 2.4-r20530 64-bit
2018-10-03 04:48:28,904  running on Linux Debian testing buster
2018-10-03 04:48:30,727 GStreamer version 1.14.3 for Python 2.7.15 64-bit

(xpra:2884): GdkGLExt-WARNING **: 04:48:30.807: Window system doesn't support OpenGL.
2018-10-03 04:48:30,807 OpenGL support could not be enabled on this hardware:
2018-10-03 04:48:30,808  OpenGL is not supported
2018-10-03 04:48:31,267  keyboard settings: rules=evdev, model=pc105, layout=pl
2018-10-03 04:48:31,675  desktop size is 1920x1080 with 1 screen:
2018-10-03 04:48:31,675   :0.0 (506x285 mm - DPI: 96x96)
2018-10-03 04:48:31,675     monitor 1 (309x174 mm - DPI: 157x157)
2018-10-03 04:48:31,886 no ethtool interface speed available for wlan0
2018-10-03 04:48:33,021 Xpra OpenGL Acceleration Failure
2018-10-03 04:48:33,021 OpenGL is not supported
2018-10-03 04:48:33,040 enabled remote logging
2018-10-03 04:48:33,040 Xpra X11 server version 2.4-r20530 64-bit
2018-10-03 04:48:33,040  running on Linux Debian testing buster
2018-10-03 04:48:33,045 no ethtool interface speed available for wlan0
2018-10-03 04:48:33,046 Attached to tcp:172.23.0.127:14300
2018-10-03 04:48:33,046  (press Control-C to detach)

2018-10-03 04:48:33,150 server does not support xi input devices
2018-10-03 04:48:33,151  server uses: xtest
2018-10-03 04:48:34,540 sound output using pulseaudio device:
2018-10-03 04:48:34,540 sound output  'Built-in Audio Analog Stereo'
2018-10-03 04:48:35,066 sound output using 'opus' audio codec
2018-10-03 04:48:44,065 server is not responding, drawing spinners over the windows
2018-10-03 04:48:44,817 server is OK again
2018-10-03 04:58:44,933 no ethtool interface speed available for wlan0
2018-10-03 04:58:44,979 sound output stopping
tbr@nestor:~$ xpra attach tcp:172.23.0.127:14300 --dpi=96 --desktop-scaling=1
Gtk-Message: 04:58:52.083: Failed to load module "atk-bridge"
2018-10-03 04:58:52,527 Xpra gtk2 client version 2.4-r20503 64-bit
2018-10-03 04:58:52,528  running on Linux Debian testing buster
2018-10-03 04:58:54,765 GStreamer version 1.14.3 for Python 2.7.15 64-bit

(xpra:648): GdkGLExt-WARNING **: 04:58:54.852: Window system doesn't support OpenGL.
2018-10-03 04:58:54,852 OpenGL support could not be enabled on this hardware:
2018-10-03 04:58:54,853  OpenGL is not supported
2018-10-03 04:58:55,307  keyboard settings: rules=evdev, model=pc105, layout=pl
2018-10-03 04:58:55,722  desktop size is 1920x1080 with 1 screen:
2018-10-03 04:58:55,722   :0.0 (506x285 mm - DPI: 96x96)
2018-10-03 04:58:55,723     monitor 1 (309x174 mm - DPI: 157x157)
2018-10-03 04:58:55,934 no ethtool interface speed available for wlan0
2018-10-03 04:58:57,117 Xpra OpenGL Acceleration Failure
2018-10-03 04:58:57,117 OpenGL is not supported
2018-10-03 04:58:57,135 enabled remote logging
2018-10-03 04:58:57,136 Xpra X11 server version 2.4-r20530 64-bit
2018-10-03 04:58:57,136  running on Linux Debian testing buster
2018-10-03 04:58:57,142 no ethtool interface speed available for wlan0
2018-10-03 04:58:57,142 Attached to tcp:172.23.0.127:14300
2018-10-03 04:58:57,143  (press Control-C to detach)

2018-10-03 04:58:57,249 server does not support xi input devices
2018-10-03 04:58:57,249  server uses: xtest
2018-10-03 04:58:58,638 sound output using pulseaudio device:
2018-10-03 04:58:58,639 sound output  'Built-in Audio Analog Stereo'
2018-10-03 04:58:59,164 sound output using 'opus' audio codec
2018-10-03 05:03:27,301 Warning: ignoring draw packet,
2018-10-03 05:03:27,304  received for a window which is not realized yet or gone already
2018-10-03 05:03:40,601 no ethtool interface speed available for wlan0
2018-10-03 05:09:48,342 Warning: ignoring draw packet,
2018-10-03 05:09:48,344  received for a window which is not realized yet or gone already

comment:2 Changed 5 months ago by Thomas B. Rücker

Summary: 2.4-20180926r20530-1 on client side can't click on anythingclient side can't click on anything

OK, different lead. It seems like it might be related to my two different client setups.

  • At work my laptop is connected additionally to two 4k Displays. xpra content mostly runs at 1920,2160 + 1080p
  • While not at work it's just the internal 1080p panel at origin 0,0

Awesome WM locks some of the windows in maximized. Not always this reaches the remote session persistently, but often some of the windows will again be maximized upon reconnecting.

Could it be that there is input coordinate confusion? AKA inputs being routed to the wrong coordinates due to stale position information? minimizing/maximizing seemed to help in one case.

Also I just went back to 2.4-20180926r20530 and didn't have input problems. So it's not a problem between the two versions, sorry for the confusion.

comment:3 Changed 3 months ago by Antoine Martin

Owner: changed from Antoine Martin to Thomas B. Rücker

Looks like this could be a duplicate of #2036

comment:4 Changed 5 weeks ago by Antoine Martin

tbr: are you using the xpra repository?
Do you have our patched dummy driver installed?
If not, then that could well be the problem: #349 (r8060 / r14584).

comment:5 Changed 5 weeks ago by Thomas B. Rücker

Resolution: duplicate
Status: newclosed

It's likely a dupe / the original report for #2036 or #2054.

Fo far I didn't have time to dig in and try to debug the cause of this myself.

Note: See TracTickets for help on using tickets.