xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 4 years ago

Last modified 13 months ago

#199 closed defect (wontfix)

vmware-gksu freezes xpra session

Reported by: ahuillet Owned by: ahuillet
Priority: major Milestone: 0.11
Component: core Version: trunk
Keywords: Cc:



I haven't tested with proper "gksu" itself, but vmware-gksu freezes the session, probably when trying to grey the screen and steal focus.

Attachments (2)

gksu-2.0.1-1.tgz (453.3 KB) - added by ahuillet 5 years ago.
libgksu-2.0.11-1.tgz (483.2 KB) - added by ahuillet 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by Antoine Martin

Status: newaccepted

I've got vmware-gksu installed, how do I make it misbehave? (works fine here when I tried via xpra..)

(also, there were a number of fixes recently with focus/window cleanup recently - maybe this is fixed already?)

comment:2 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to ahuillet
Status: acceptedassigned

comment:3 Changed 5 years ago by Antoine Martin

Milestone: 0.80.9

ahuillet: please update this ticket

comment:4 Changed 5 years ago by ahuillet

I still have the problem. Running vmware-gksu on a (Xvfb-based) Xpra session locks it up for good - I can't input my password nor do anything.

latest trunk as of this writing, up-to-date Archlinux on client and server

Last edited 5 years ago by ahuillet (previous) (diff)

comment:5 Changed 5 years ago by Antoine Martin

Well, that's a PITA.
The "current" version is gnome's polkit gksu and that worked ok after I started the gksu-server. But it failed when I tried as a user which did not already have a real desktop session running. I guess the polkit part piggybacks on the existing display connection? Who knows:

  • No man page
  • No gksu-server --help either...

Then there's also the original gksu, but after downloading a gazillion dependencies, the Makefile is broken (tabs vs spaces) and even after fixing it doesn't build cleanly on Fedora 18:

libtool: link: gcc -g -O2 -Wall -g -O2 -o test-gksuui test-gksuui.o  \
    ./.libs/libgksuui1.0.a -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 \
    -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 \
    -lfreetype -lfontconfig -lgobject-2.0 -lgconf-2 -lglib-2.0
/usr/bin/ld: ./.libs/libgksuui1.0.a(gksuui-dialog.o): undefined reference to symbol 'XkbGetState'
/usr/bin/ld: note: 'XkbGetState' is defined in DSO /lib64/libX11.so.6 \
    so try adding it to the linker command line
/lib64/libX11.so.6: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status

Adding -lX11 fixes that, then the ui build needs -lgtk-x11-2.0 added to fix yet another compile error.

Eventually, one can get gksu installed and it works ok via xpra too.. fullscreen and everything.

It looks to me like the vmware version is a fork/copy of gksu, which is GPLv2 so maybe someone can ask them for the source then we can figure out what it does different?

Changed 5 years ago by ahuillet

Attachment: gksu-2.0.1-1.tgz added

Changed 5 years ago by ahuillet

Attachment: libgksu-2.0.11-1.tgz added

comment:6 Changed 5 years ago by ahuillet

Attached source files from VMWare's "open source" package.

comment:7 Changed 5 years ago by Antoine Martin

Status: assignednew

In gksu-2.0.1-1.tgz, we find:


The archive is the same as upstream and the patch is irrelevant to us (only applies on command exit)

And in libgksu-2.0.11-1.tgz, we find a source RPM!?:


The RPM contains:

$ cd ~/rpmbuild;ls -la *


To try to build on Fedora 18, I needed to patch the specfile and replace libgtop-devel with libgtop2-devel.
But then:

rpmbuild -ba SPECS/libgksu.spec 
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.WJ8Ixj
+ umask 022
+ cd /home/antoine/rpmbuild/BUILD
+ cd /home/antoine/rpmbuild/BUILD
+ rm -rf libgksu-2.0.11
+ /usr/bin/gzip -dc /home/antoine/rpmbuild/SOURCES/libgksu-2.0.11.tar.gz
+ /usr/bin/tar -xf -
+ '[' 0 -ne 0 ']'
+ cd libgksu-2.0.11
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ echo 'Patch #0 (libgksu-2.0.11-nogconf.patch):'
Patch #0 (libgksu-2.0.11-nogconf.patch):
+ /usr/bin/cat /home/antoine/rpmbuild/SOURCES/libgksu-2.0.11-nogconf.patch
+ /usr/bin/patch -p1 --fuzz=0
patching file configure.ac
patching file gksu-properties/gksu-properties.c
patching file gksu-properties/gksu-properties.desktop.in
patching file gksu-properties/gksu-properties.glade
patching file gksu-properties/Makefile.am
patching file libgksu/libgksu2.pc.in
patching file libgksu/libgksu.c
Hunk #1 FAILED at 2.
Hunk #2 succeeded at 44 (offset 1 line).
Hunk #3 succeeded at 1936 (offset 4 lines).
Hunk #4 succeeded at 1956 (offset 4 lines).
Hunk #5 succeeded at 1991 (offset 4 lines).
Hunk #6 succeeded at 2004 (offset 4 lines).
1 out of 6 hunks FAILED -- saving rejects to file libgksu/libgksu.c.rej
patching file libgksu/libgksu.h
patching file libgksu/Makefile.am
patching file libgksuui/gconf-stub.c
patching file libgksuui/gksuui-dialog.c
patching file libgksuui/gnome-keyring-stub.c
patching file libgksuui/Makefile.am
patching file Makefile.am
patching file patches/gconf-stub.h
patching file patches/gnome-keyring-stub.h
error: Bad exit status from /var/tmp/rpm-tmp.WJ8Ixj (%prep)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.WJ8Ixj (%prep)

Looks to me like this source RPM is just broken and does not build as it is.
So, not only is this an outdated version, it has random patches that don't apply cleanly - is it really worth pursuing?

comment:8 Changed 5 years ago by Antoine Martin

Milestone: 0.9future

not going to deal with this for 0.9.x for sure

comment:9 Changed 4 years ago by Antoine Martin

Resolution: wontfix
Status: newclosed

Old, closing - though focus/grabs will be revisited in 0.12

comment:10 Changed 13 months ago by Antoine Martin

Milestone: future0.11

(edit milestone)

Note: See TracTickets for help on using tickets.