xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#2009 closed defect (fixed)

Clipboard regression (client --> server)

Reported by: onlyjob Owned by: onlyjob
Priority: major Milestone: 2.5
Component: clipboard Version: 2.4.x
Keywords: Cc:

Description

After upgrading client to 2.4 I can not paste anything to server any more. Client complains with Warning: sanitizing invalid gtk selection. Server is still 2.3.4; copy on server and paste on client works (but not vice versa).

Change History (3)

comment:1 Changed 2 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to onlyjob

(please always post the full exact warning message)
The problem was caused by r20411. The fix is in r20845.

@onlyjob: please close this ticket if the fix works for you.

The problem with this series of changes is that the behaviour is different from one version of GTK to another, from one platform to another, from one DE to another (clipboard applets wrecking havoc, Java apps spamming #2013), etc.
So it is possible that this fix will cause a regression (crash?) somewhere, though I have been unable to reproduce any of the ones that were originally recorded (see #1579, #1601).

comment:2 Changed 2 weeks ago by onlyjob

Resolution: fixed
Status: newclosed

Thanks very much - r20845 works perfectly.

By the way I believe I've quoted full exact warning message - I don't recall seeing anything but "Warning: sanitizing invalid gtk selection"...

comment:3 Changed 2 weeks ago by Antoine Martin

Duplicate: #2019

Note: See TracTickets for help on using tickets.