xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

Last modified 2 months ago

#2010 closed defect (duplicate)

Gnome-terminal + xpra start/attach issues

Reported by: stdedos Owned by: stdedos
Priority: major Milestone: 2.5
Component: clipboard Version: 2.4.x
Keywords: Cc:

Description

Continuing from #1997 for the gnome-terminal

I have the issue that
$ xpra start :30 --start-child=gnome-terminal --terminate-children=yes --exit-with-children=yes

fails most of the times, whereas
$ xpra start :30 --start-child=xterm --terminate-children=yes --exit-with-children=yes
starts correctly.

$ xpra start :30 --start-child=xterm --terminate-children=yes --exit-with-children=yes
and then gnome-terminal works all the time.

Bugs:

  1. After xpra start :30 [...] I need to xpra attach :30 [...]. Is that expected?

2.

  • $ xpra start :30 --start-child=xterm --terminate-children=yes --exit-with-children=yes
  • Then start gnome-terminal
  • Disconnect
  • Reattach
  • gnome-terminal works, but sometimes (1 out of 7-10) xterm is frozen. Killing and re-attaching the xpra window fixes that

Attachments (2)

xterm+gnome-terminal_freeze.zip (66.5 KB) - added by stdedos 3 months ago.
trac_2010_new-attempt.zip (164.7 KB) - added by stdedos 2 months ago.

Download all attachments as: .zip

Change History (7)

Changed 3 months ago by stdedos

comment:1 Changed 3 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

Please see wiki/ReportingBugs to provide additional information.

After xpra start :30 [...] I need to xpra attach :30 [...]. Is that expected?

Yes.
You can do all in one with --attach=yes.

but sometimes (1 out of 7-10) xterm is frozen

Do I need to start again or just detach + re-attach to trigger this?
Your log is full of:

Warning: more than 30 clipboard requests per second!

My guess is that you have a clipboard loop. Disable clipboard or disable the other tool that is doing the clipboard synchronization.
This is probably not a bug.

comment:2 in reply to:  1 Changed 3 months ago by stdedos

Resolution: duplicate
Status: newclosed

Replying to Antoine Martin:

Please see wiki/ReportingBugs to provide additional information.

I understand that I am not good at bug reports. However, since I've taken xpra Information > Report Bug, I am not sure what did I miss.

$ xpra start goes from/to Ubuntu 16.04.5, but this is the only thing that comes to mind.

Do I need to start again or just detach + re-attach to trigger this?

Detach and re-attach is enough.

Your log is full of:

Warning: more than 30 clipboard requests per second!

My guess is that you have a clipboard loop. Disable clipboard or disable the other tool that is doing the clipboard synchronization.

Disabling the clipboard was helpful for this session. I am not sure how the loop works, but, I guess since I had other sessions open at the same time, maybe the sync was complicated?

There was no "external" connection; neither a shadow server. Only multiples of xterm, gnome-terminal

comment:3 Changed 3 months ago by Antoine Martin

I am not sure how the loop works, but, I guess since I had other sessions open at the same time, maybe the sync was complicated?

If any of the sessions is connected at either end (server or client) to a tool that abuses the X11 clipboard synchronization mechanism, you will see this problem.

The usual culprits are: synergy, virtualbox, clipboard managers, etc..

The better, long term solution for this is #812

Last edited 3 months ago by Antoine Martin (previous) (diff)

comment:4 Changed 2 months ago by stdedos

It happened again. Unfortunately, I have no replication instructions :/

I ran the command once, it gave me the empty window. I ran it again, and I collected all the diagnostics through that session :/

I hope the collected diagnostics are helpful

command

"C:\Program Files\Xpra\xpra_cmd" start ssh://user@ip/ --webcam=no --speaker=off --microphone=off --opengl=no --start=gnome-terminal

Note that cliboard sync was on. But it doesn't matter (I hope), because I got it happening 1 times out of 3~5, even with client clipboard off

"C:\Program Files\Xpra\xpra_cmd" start ssh://sntentos@172.16.57.121/ --webcam=no --cliboard=no --speaker=off --microphone=off --opengl=no --start=gnome-terminal

Changed 2 months ago by stdedos

Attachment: trac_2010_new-attempt.zip added

comment:5 Changed 2 months ago by Antoine Martin

Component: androidclipboard
Note: See TracTickets for help on using tickets.