xpra icon
Bug tracker and wiki

Opened 5 weeks ago

Closed 2 weeks ago

#2034 closed defect (invalid)

Cannot start evolution inside xpra

Reported by: stdedos Owned by: stdedos
Priority: minor Milestone: 2.5
Component: server Version: 2.4.x
Keywords: Cc:

Description

Neither

xpra start :999 --start-child=evolution --attach=yes --exit-with-children=yes

nor

xpra start :999 --start-child=xterm --attach=yes --exit-with-children=yes

work.

Directly starting evolution gives no output, while with xterm:
$ evolution

(evolution:29846): GLib-CRITICAL : g_strsplit: assertion 'string != NULL' failed
Segmentation fault (core dumped)

Attached xpra info, and the crash dumps

Attachments (1)

cannot_start_evolution.tar.bz2 (3.3 MB) - added by stdedos 5 weeks ago.

Change History (4)

Changed 5 weeks ago by stdedos

comment:1 Changed 5 weeks ago by stdedos

Direct invocation's crash dump cannot be attached due to file size limitations; please advise if needed

comment:2 Changed 5 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

Please don't attach archives with yet more archives in them.
It's not clear what is what either and I don't have time to sift through all this to figure it out. The key information I spotted so far:

  • client and server are running Ubuntu 16.04 64-bit
  • xpra version 2.4.1-r20907

If evolution is crashing, then it may well be a bug in evolution. Please try to get a gdb backtrace from evolution.
I've tried with Ubuntu 16.04 and evolution launched correctly, showed me the welcome wizard dialog.

comment:3 Changed 2 weeks ago by Antoine Martin

Resolution: invalid
Status: newclosed

Likely an evolution bug, I cannot reproduce here.

Note: See TracTickets for help on using tickets.