xpra icon
Bug tracker and wiki

Opened 5 weeks ago

Closed 4 weeks ago

Last modified 4 weeks ago

#2036 closed defect (invalid)

Windows don't receive input after reconnecting until minimize/maximize - WM: Awesome

Reported by: Thomas B. Rücker Owned by: Thomas B. Rücker
Priority: minor Milestone: 2.5
Component: server Version: trunk
Keywords: Cc:

Description

Debian Buster
awesome 4.2-5
xpra 2.5-20181113r20979-1

Has been like this for a while. Maybe a bit before 2.4 shipped?

I need to minimize/maximize windows after reconnecting, otherwise they don't receive any input events. Neither mouse nor keyboard.

Change History (11)

comment:1 Changed 5 weeks ago by Thomas B. Rücker

it might be because of the location on the client side.

  • At work I run 2x4k+1k.
  • At home it's just the 1k internal screen.
  • The offset is roughly 1920x2160 at work, and 0x0 at home

I also get weird effects where context menus will be on the other end of the screen or might not receive mouse input although the application does and keyboard input works.

Client is running without openGL as I've had issues to get to a stable combination of recent kernel and either nvidia or intel graphics…

comment:2 Changed 5 weeks ago by Thomas B. Rücker

At work (ssh tunnel):

xpra attach tcp:localhost:14300 --dpi=96 --desktop-scaling=1
Gtk-Message: 08:08:00.692: Failed to load module "atk-bridge"

(Xpra:7797): GdkGLExt-WARNING **: 08:08:00.719: Window system doesn't support OpenGL.
error=OpenGL is not supported
Gtk-Message: 08:08:00.842: Failed to load module "atk-bridge"
2018-11-14 08:08:01,471 Xpra gtk2 client version 2.5-r20979 64-bit
2018-11-14 08:08:01,473  running on Linux Debian testing buster
2018-11-14 08:08:01,474  window manager is 'awesome'
2018-11-14 08:08:03,869 GStreamer version 1.14.4 for Python 2.7.15 64-bit

(xpra:7679): GdkGLExt-WARNING **: 08:08:04.001: Window system doesn't support OpenGL.
2018-11-14 08:08:04,001 OpenGL support could not be enabled on this hardware:
2018-11-14 08:08:04,001  OpenGL is not supported
2018-11-14 08:08:04,615  keyboard settings: rules=evdev, model=pc105, layout=pl
2018-11-14 08:08:05,102  desktop size is 7680x3240 with 1 screen:
2018-11-14 08:08:05,102   :0.0 (2026x855 mm - DPI: 96x96)
2018-11-14 08:08:05,103     monitor 2 3840x2160 (597x336 mm - DPI: 163x163)
2018-11-14 08:08:05,103     monitor 3 1920x1080 at 1920x2160 (309x174 mm - DPI: 157x157)
2018-11-14 08:08:05,103     monitor 4 3840x2160 at 3840x0 (597x336 mm - DPI: 163x163)
2018-11-14 08:08:06,801 enabled remote logging
2018-11-14 08:08:06,802 Xpra X11 server version 2.5-r20681 64-bit
2018-11-14 08:08:06,803  running on Linux Debian testing buster
2018-11-14 08:08:06,818 Attached to tcp:localhost:14300
2018-11-14 08:08:06,818  (press Control-C to detach)

2018-11-14 08:08:06,980 server does not support xi input devices
2018-11-14 08:08:06,980  server uses: xtest
2018-11-14 08:08:09,013 sound output using pulseaudio device:
2018-11-14 08:08:09,023 sound output  'Built-in Audio Analog Stereo'
2018-11-14 08:08:09,564 sound output using 'opus' audio codec
2018-11-14 11:26:54,777 server is not responding, drawing spinners over the windows
2018-11-14 11:26:55,045 server is OK again
2018-11-14 11:27:54,799 server is not responding, drawing spinners over the windows
2018-11-14 11:27:55,301 server is OK again
2018-11-14 11:32:39,919 server is not responding, drawing spinners over the windows
2018-11-14 11:32:40,420 server is OK again
2018-11-14 11:44:55,189 server is not responding, drawing spinners over the windows
2018-11-14 11:44:55,692 server is OK again
2018-11-14 11:45:15,203 server is not responding, drawing spinners over the windows
2018-11-14 11:45:16,708 server is OK again
2018-11-14 12:15:30,787 server is not responding, drawing spinners over the windows
2018-11-14 12:15:31,039 server is OK again
2018-11-14 13:01:36,707 server is not responding, drawing spinners over the windows
2018-11-14 13:01:38,215 server is OK again
2018-11-14 13:15:36,970 server is not responding, drawing spinners over the windows
2018-11-14 13:15:38,981 server is OK again

2018-11-14 14:28:36,588 sending updated screen size to server: 1920x1080 with 1 screens
2018-11-14 14:28:36,599   :0.0 (506x285 mm - DPI: 96x96)
2018-11-14 14:28:36,600     monitor 2 (309x174 mm - DPI: 157x157)


At home:

tbr@nestor:~$ xpra attach tcp:172.16.0.42:14300 --dpi=96 --desktop-scaling=1
Gtk-Message: 14:54:00.668: Failed to load module "atk-bridge"

(Xpra:9696): GdkGLExt-WARNING **: 14:54:00.699: Window system doesn't support OpenGL.
error=OpenGL is not supported
Gtk-Message: 14:54:00.794: Failed to load module "atk-bridge"
2018-11-14 14:54:01,440 Xpra gtk2 client version 2.5-r20979 64-bit
2018-11-14 14:54:01,441  running on Linux Debian testing buster
2018-11-14 14:54:01,441  window manager is 'awesome'
2018-11-14 14:54:03,784 GStreamer version 1.14.4 for Python 2.7.15 64-bit

(xpra:9638): GdkGLExt-WARNING **: 14:54:03.901: Window system doesn't support OpenGL.
2018-11-14 14:54:03,901 OpenGL support could not be enabled on this hardware:
2018-11-14 14:54:03,902  OpenGL is not supported
2018-11-14 14:54:04,336  keyboard settings: rules=evdev, model=pc105, layout=pl
2018-11-14 14:54:04,755  desktop size is 1920x1080 with 1 screen:
2018-11-14 14:54:04,755   :0.0 (506x285 mm - DPI: 96x96)
2018-11-14 14:54:04,755     monitor 2 (309x174 mm - DPI: 157x157)
2018-11-14 14:54:04,961 no ethtool interface speed available for wlan0
2018-11-14 14:54:06,197 enabled remote logging
2018-11-14 14:54:06,198 Xpra X11 server version 2.5-r20681 64-bit
2018-11-14 14:54:06,198  running on Linux Debian testing buster
2018-11-14 14:54:06,213 Attached to tcp:172.23.0.127:14300
2018-11-14 14:54:06,214  (press Control-C to detach)

2018-11-14 14:54:06,367 server does not support xi input devices
2018-11-14 14:54:06,368  server uses: xtest
2018-11-14 14:54:08,254 sound output using pulseaudio device:
2018-11-14 14:54:08,255 sound output  'Built-in Audio Analog Stereo'
2018-11-14 14:54:08,798 sound output using 'opus' audio codec

4 GUI Apps are running:

  • Firefox +
  • Thunderbird +
  • Deluge-GTK +
  • Xterm

Apps marked with a "+" are maximized, those apps don't accept any kind of pointer input events, keyboard still works.

Before disconnecting external screens those apps were at ~ 1920x2160, upon connection stall/timeout they should have been at 0x0, now they are at ~0x0 (modulo top of each screen having the Awesome status bar).
Minimizing and maximizing the apps restores pointer interaction.

Xterm works with mouse and keyboard.

comment:3 Changed 5 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to Thomas B. Rücker

Minimizing and maximizing the apps restores pointer interaction.

Disconnecting and connecting again is meant to have the same effect.
But, maybe the screen has not finished resizing when we restore the windows.

This could also be because of a bug in the dummy driver: #1467

@tbr: which dummy driver package are you using? (full version details please)

comment:4 Changed 4 weeks ago by Thomas B. Rücker

could be related, yes

apt policy xserver-xorg-video-dummy
xserver-xorg-video-dummy:
  Installed: 1:0.3.8-1+b1
  Candidate: 1:0.3.8-1+b1
  Version table:
 *** 1:0.3.8-1+b1 500
        500 http://ftp.se.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
[    33.933] (II) LoadModule: "dummy"
[    33.937] (II) Loading /usr/lib/xorg/modules/drivers/dummy_drv.so
[    33.937] (II) Module dummy: vendor="X.Org Foundation"
[    33.937]    compiled for 1.20.0, module version = 0.3.8
[    33.937]    Module class: X.Org Video Driver
[    33.937]    ABI class: X.Org Video Driver, version 24.0

comment:5 Changed 4 weeks ago by Antoine Martin

So you aren't installing xpra from the repository, please mention that early as per wiki/ReportingBugs.
My bet is that the patched dummy driver will fix your problems and I can close this ticket as invalid.

comment:6 Changed 4 weeks ago by Thomas B. Rücker

I'm installing Xpra from the beta repository.
There is *no* xserver-xorg-video-dummy in there and xpra doesn't depend on a patched/fixed version of that package. Else it would be in the apt-policy output.

You may consider this invalid, but following your reasoning it's caused by the beta repository not providing a necessary package.

comment:7 Changed 4 weeks ago by Antoine Martin

Resolution: invalid
Status: newclosed

The beta repository is a supplemental one, as per the download page: The beta repositories are supplemental ones so you must also configure the stable repository to use them.

(and the patched dummy is in the stable repo for buster)

Last edited 4 weeks ago by Antoine Martin (previous) (diff)

comment:8 Changed 4 weeks ago by Thomas B. Rücker

I'd love to see if that fixes it, but:

apt policy xserver-xorg-video-dummy
xserver-xorg-video-dummy:
  Installed: 1:0.3.8-1+b1
  Candidate: 1:0.3.8-5
  Version table:
     1:0.3.8-5 500
        500 http://xpra.org buster/main amd64 Packages
 *** 1:0.3.8-1+b1 500
        500 http://ftp.se.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
apt install xserver-xorg-video-dummy=1:0.3.8-5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-video-dummy : Depends: xorg-video-abi-23 but it is not installable
E: Unable to correct problems, you have held broken packages.
 apt install xorg-video-abi-23
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package xorg-video-abi-23 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'xorg-video-abi-23' has no installation candidate

https://packages.debian.org/search?keywords=xorg-video-abi-23&searchon=names&suite=all&section=all
→ Sorry, your search gave no results

https://packages.debian.org/buster/xorg-video-abi-23  → Package not available in this suite.
https://packages.debian.org/sid/xorg-video-abi-23 → Packages providing xorg-video-abi-23: xserver-xorg-core xserver-xorg-core-udeb

root@puck:/run/user/1000/xpra# apt show xserver-xorg-core
Package: xserver-xorg-core
Version: 2:1.20.3-1
Priority: optional
Section: x11
Source: xorg-server
Maintainer: Debian X Strike Force <debian-x@lists.debian.org>
Installed-Size: 6,093 kB
Provides: xorg-input-abi-24, xorg-video-abi-24, xserver-xorg-video-modesetting
Depends: xserver-common (>= 2:1.20.3-1), keyboard-configuration, udev (>= 149), libegl1-mesa | libegl1, libaudit1 (>= 1:2.2.1), libbsd0 (>= 0.7.0), libc6 (>= 2.17), libdbus-1-3 (>= 1.9.14), libdrm2 (>= 2.4.66), libepoxy0 (>= 1.4.3), libgbm1 (>= 17.1.0~rc2), libgcrypt20 (>= 1.8.0), libgl1, libpciaccess0 (>= 0.12.902), libpixman-1-0 (>= 0.30.0), libselinux1 (>= 2.0.82), libsystemd0, libudev1 (>= 183), libunwind8, libxau6, libxdmcp6, libxfont2 (>= 1:2.0.1), libxshmfence1
Recommends: libgl1-mesa-dri (>= 7.10.2-4), libpam-systemd
Suggests: xfonts-100dpi | xfonts-75dpi, xfonts-scalable
Conflicts: xserver-xorg-input-evtouch, xserver-xorg-video-modesetting
Breaks: libgl1-mesa-dri (<< 18.0.5), systemd (<< 226-4~), xserver-xorg (<< 1:7.7+10~)
Replaces: xserver-xorg (<< 1:7.7+10~), xserver-xorg-video-modesetting
Homepage: https://www.x.org/
Tag: hardware::input, hardware::video, implemented-in::c, interface::daemon,
 interface::graphical, interface::x11, network::server, role::program,
 uitoolkit::xlib, use::driver, x11::application, x11::xserver
Download-Size: 3,529 kB
APT-Manual-Installed: no
APT-Sources: http://ftp.se.debian.org/debian testing/main amd64 Packages
Description: Xorg X server - core server
 The Xorg X server is an X server for several architectures and operating
 systems, which is derived from the XFree86 4.x series of X servers.
 .
 The Xorg server supports most modern graphics hardware from most vendors,
 and supersedes all XFree86 X servers.
 .
 More information about X.Org can be found at:
 <URL:https://www.x.org>
 .
 This package is built from the X.org xserver module.

Your repository is broken and needs to be rebuilt against current buster.

comment:9 Changed 4 weeks ago by Antoine Martin

Your repository is broken and needs to be rebuilt against current buster.

Buster keeps on breaking, that's what "testing" means.

comment:10 Changed 4 weeks ago by Thomas B. Rücker

Yes and problems are usually meant to be reported so that they can be fixed. That's what "testing" means.

comment:11 Changed 4 weeks ago by Antoine Martin

An updated dummy driver is now in both stable and beta repositories.

Last edited 4 weeks ago by Antoine Martin (previous) (diff)
Note: See TracTickets for help on using tickets.