xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 3 months ago

Last modified 3 months ago

#2042 closed defect (fixed)

Failed to add PIDs to scope's control group: Permission denied

Reported by: Ramiro Owned by: Antoine Martin
Priority: major Milestone: 2.5
Component: core Version: 2.1.x
Keywords: Cc: snhirsch@…

Description

I am on the server side, an Ubuntu 18.04, with xpra version 2.1.3.

When I try:

rmagno@r2d2:~$ PATH="/usr/lib/xorg:$PATH" xpra start --bind-tcp=0.0.0.0:14500 --html=on --start=xterm

I get:

using systemd-run to wrap 'start' server command
'systemd-run' '--description' 'xpra-start' '--scope' '--user' '/usr/bin/xpra' 'start' '--bind-tcp=0.0.0.0:14500' '--html=on' '--start=xterm' '--systemd-run=no'
Job for run-rc4c6fd6f0a8445b08d9bfb1da717308c.scope failed.
See "systemctl status run-rc4c6fd6f0a8445b08d9bfb1da717308c.scope" and "journalctl -xe" for details.

then journalctl -xe shows me:

Nov 16 07:35:28 r2d2 systemd[26686]: run-rb32e0e35376249e1b0d77b784c1beffb.scope: Failed to add PIDs to scope's control group: Permission denied
Nov 16 07:35:28 r2d2 systemd[26686]: run-rb32e0e35376249e1b0d77b784c1beffb.scope: Failed with result 'resources'.
Nov 16 07:35:28 r2d2 systemd[26686]: Failed to start xpra-start.

Attachments (1)

snap.png (38.5 KB) - added by Ramiro 5 months ago.
connect.html error msg

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 months ago by Antoine Martin

Resolution: invalid
Status: newclosed

Is this from an SSH session? This works fine from a regular terminal in my Ubuntu 18.04 VM.

That said, I'm using a supported version (2.4.1) and you are not (2.1.3).
Please do not use the version provided by the Ubuntu repositories which is fundamentally broken and insecure (more details here: wiki/Packaging/DistributionPackages)

comment:2 Changed 5 months ago by Ramiro

Resolution: invalid
Status: closedreopened

Could you please instruct me on how to install version 2.4.1 under Ubuntu 18.04?

And yes, I am trying to run that command from an SSH session.

BTW: How to check xpra version?

Last edited 5 months ago by Ramiro (previous) (diff)

Changed 5 months ago by Ramiro

Attachment: snap.png added

connect.html error msg

comment:3 Changed 5 months ago by Antoine Martin

Resolution: invalid
Status: reopenedclosed

Could you please instruct me on how to install version 2.4.1 under Ubuntu 18.04?

See wiki/Download.

And yes, I am trying to run that command from an SSH session.

This can cause problems under some circumstances.
If you still encounter issues after upgrading, start your sessions first, then connect over ssh - rather than doing all in one.

BTW: How to check xpra version?

xpra --version

comment:4 Changed 3 months ago by snhirsch

Resolution: invalid
Status: closedreopened

I suddenly started seeing exactly the same symptoms on my Ubuntu 18.04 system when running from a standard Xterm (NOT ssh session). Was working fine until several days ago when, I suspect, a Ubuntu update broke it.

I followed the directions to install directly from your repository, but apparently the Ubuntu package is newer and nothing was brought down.

xpra --version yields: xpra v2.5-r21174

Last edited 3 months ago by Antoine Martin (previous) (diff)

comment:5 Changed 3 months ago by snhirsch

Cc: snhirsch@… added

comment:6 Changed 3 months ago by snhirsch

More information: The root cause of this problem is related to cgroup permissions. If I hack ownership with this script things start working again.

#!/usr/bin/env bash

set -euo pipefail

file=/sys/fs/cgroup/unified/user.slice/user-$(id -u).slice/cgroup.procs

sudo chown $(whoami):root $file
sudo chmod g+w            $file
Last edited 3 months ago by Antoine Martin (previous) (diff)

comment:7 Changed 3 months ago by Antoine Martin

Resolution: fixed
Status: reopenedclosed

I followed the directions to install directly from your repository, but apparently the Ubuntu package is newer and nothing was brought down.
xpra --version yields: xpra v2.5-r21174

Looks like you're using the beta channel.

Try the stable 2.4.3, which has this fix: r21227
Otherwise, I'll try to make new beta builds shortly.

You can also do:

echo "systemd-run=no" >> ~/.xpra/xpra.conf

comment:8 Changed 3 months ago by snhirsch

I am not using the beta channel. My winswitch.list file contains:

deb http://winswitch.org/ bionic main

There are no other references to winswitch anywhere in the apt configuration tree.

comment:9 Changed 3 months ago by Antoine Martin

I am not using the beta channel.

There are no 2.5 builds in the stable repository.
I have no idea how it landed on your system.

Maybe try:

apt-get update
apt-get remove -y xpra
apt-get install -y xpra
Note: See TracTickets for help on using tickets.