xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#2062 closed defect (fixed)

build_info.py varies across builds

Reported by: Bernhard M. Wiedemann Owned by: Antoine Martin
Priority: minor Milestone: 2.5
Component: server Version: 2.4.x
Keywords: Cc:

Description

While working on reproducible builds for openSUSE, I found that
the xpra package varied for every build
because of variations in build_info.py

With the attached patch, it is possible to avoid these variations
and create identical packages anywhere anytime

Attachments (1)

reproducible.patch (3.3 KB) - added by Bernhard M. Wiedemann 3 months ago.

Download all attachments as: .zip

Change History (4)

Changed 3 months ago by Bernhard M. Wiedemann

Attachment: reproducible.patch added

comment:1 Changed 3 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks for the patch.

I've merged it with some changes since we can't drop useful data just because some platforms have no need for it: r21103.

Feel free to re-open if I've missed something.

comment:2 Changed 3 months ago by Bernhard M. Wiedemann

I tested that your variant worked. For that I had to pull the diff out of svn, which trac would not let me do, so I created https://github.com/bmwiedemann/xpra and keep it up-to-date via a cron-job for everyone's convenience.

comment:3 Changed 3 months ago by Antoine Martin

For that I had to pull the diff out of svn, which trac would not let me do

Every trac patch page has a link to the raw patch, at the bottom of the page under Download in other formats.
You can also use svn from the command line as per SVN create patch from committed code.

Note: See TracTickets for help on using tickets.