xpra icon
Bug tracker and wiki

Opened 2 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#2067 closed defect (invalid)

websockify cannot be found

Reported by: SpaceboyRoss Owned by: Antoine Martin
Priority: major Milestone: 2.5
Component: server Version: 2.4.x
Keywords: websockify, archlinux Cc:

Description (last modified by Antoine Martin)

OS: Arch Linux
CPU: amd64
Changes to config: No
Network: LAN/WiFi
Client Command: none since trying to connect using OS.js
Server Command: sudo xpra start :1 --bind-ws=0.0.0.0:8001
Note: using xpra without sudo results in a different error
Install method: yay (yet another yaourt)
Path: /home/spaceboyross/.nvm/versions/node/v8.12.0/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/opt/cuda/bin:/home/spaceboyross/.local/share/flatpak/exports/bin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/home/spaceboyross/bin:/home/spaceboyross/toolchain/bin:/home/spaceboyross/bin:/home/spaceboyross/toolchain/bin
Log:

2018-11-30 10:35:15,667 cannot use uinput for virtual devices:
2018-11-30 10:35:15,667  [Errno 19] Failed to open the uinput device: No such device

X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
Build Operating System: Linux Arch Linux
Current Operating System: Linux RX-178_Gundam_Mk-II 4.19.4-arch1-1-ARCH #1 SMP PREEMPT Fri Nov 23 09:06:58 UTC 2018 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=56844737-5f5c-49cb-8278-9e8e35186561 rw quiet
Build Date: 25 October 2018  04:42:32PM
 
Current version of pixman: 0.36.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/tmp/Xorg.:1.log", Time: Fri Nov 30 10:35:15 2018
(++) Using config file: "/etc/xpra/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xauth:  timeout in locking authority file /home/spaceboyross/.Xauthority
2018-11-30 10:35:35,682 Warning: xauth command took 20 seconds and failed
2018-11-30 10:35:35,683 Warning: trying to clean some stale xauth locks
2018-11-30 10:35:35,731 Warning: failed to create socket directory '/run/user/0/xpra'
2018-11-30 10:35:35,731  [Errno 2] No such file or directory: '/run/user/0/xpra'
2018-11-30 10:35:35,731 Warning: cannot create socket '/run/user/0/xpra/RX-178_Gundam_Mk-II-1':
2018-11-30 10:35:35,731  [Errno 2] No such file or directory
2018-11-30 10:35:35,732  ($XDG_RUNTIME_DIR has not been created?)
2018-11-30 10:35:35,733 created unix domain socket: /run/xpra/RX-178_Gundam_Mk-II-1
2018-11-30 10:35:35,834 pointer device emulation using XTest
2018-11-30 10:35:36,330  OpenGL is supported on this display
2018-11-30 10:35:36,371 html server unavailable, cannot find websockify module
2018-11-30 10:35:36,412 D-Bus notification forwarding is available
2018-11-30 10:35:36,483 Warning: webcam forwarding is disabled
2018-11-30 10:35:36,483  the virtual video directory '/sys/devices/virtual/video4linux' was not found
2018-11-30 10:35:36,483  make sure that the 'v4l2loopback' kernel module is installed and loaded
2018-11-30 10:35:36,483 found 0 virtual video devices for webcam forwarding
2018-11-30 10:35:36,487 Warning: the runtime directory '%s' does not exist,
2018-11-30 10:35:36,487  cannot start a private pulseaudio server
2018-11-30 10:35:36,494 pulseaudio server started with pid 31603
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).

Warning: running as root

(gst-plugin-scanner:31709): GStreamer-WARNING **: 10:35:36.971: Failed to load plugin '/usr/lib/gstreamer-1.0/libgstlv2.so': liblilv-0.so.0: cannot open shared object file: No such file or directory

(gst-plugin-scanner:31709): GStreamer-WARNING **: 10:35:37.300: Failed to load plugin '/usr/lib/gstreamer-1.0/libgstkate.so': libkate.so.1: cannot open shared object file: No such file or directory

(gst-plugin-scanner:31709): GStreamer-WARNING **: 10:35:37.363: Failed to load plugin '/usr/lib/gstreamer-1.0/libgstzbar.so': libzbar.so.0: cannot open shared object file: No such file or directory
2018-11-30 10:35:37,652 GStreamer version 1.14.4 for Python 2.7.15 64-bit
2018-11-30 10:35:37,743 xpra X11 version 2.4.1-r20899 64-bit
2018-11-30 10:35:37,744  uid=0 (root), gid=0 (root)
2018-11-30 10:35:37,744  running with pid 31375 on Linux Arch rolling n/a
2018-11-30 10:35:37,744  connected to X11 display :1 with 24 bit colors
2018-11-30 10:35:37,846 11.7GB of system memory
2018-11-30 10:35:37,848 failed to connect to avahi's dbus interface: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.freedesktop.Avahi.service not found.
2018-11-30 10:35:37,848  to avoid this warning, disable mdns support 
2018-11-30 10:35:37,848  using the 'mdns=no' option
2018-11-30 10:35:37,848 failed to connect to avahi's dbus interface: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.freedesktop.Avahi.service not found.
2018-11-30 10:35:37,848  to avoid this warning, disable mdns support 
2018-11-30 10:35:37,848  using the 'mdns=no' option
2018-11-30 10:35:37,849 xpra is ready.
Exception in thread GET-request-for-127.0.0.1:33024:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 801, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.7/threading.py", line 754, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/xpra/server/server_core.py", line 1148, in start_websockify
    from xpra.server.websocket import WebSocketConnection, WSRequestHandler
  File "/usr/lib/python2.7/site-packages/xpra/server/websocket.py", line 28, in <module>
    from websockify.websocket import WebSocketRequestHandler    #@Reimport
ImportError: No module named websockify.websocket

Change History (6)

comment:1 Changed 2 weeks ago by Antoine Martin

Description: modified (diff)
Resolution: invalid
Status: newclosed

You have to install websockify.

comment:2 Changed 2 weeks ago by Antoine Martin

Note: using xpra without sudo results in a different error

Please report the problem to your distro packager.

comment:3 Changed 2 weeks ago by SpaceboyRoss

Resolution: invalid
Status: closedreopened

Running xpra without root results in:

2018-11-30 10:58:52,956 cannot use uinput for virtual devices:
2018-11-30 10:58:52,956  [Errno 19] Failed to open the uinput device: No such device
(EE) 
Fatal server error:
(EE) 
Invalid argument -logfile with elevated privileges
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) 
2018-11-30 10:58:55,979 Error: failed to connect to display :1
2018-11-30 10:58:55,979  could not connect to X server on display ':1' after 3 seconds

And I've installed a package called python2-websockify-client but i still get the error

Last edited 2 weeks ago by Antoine Martin (previous) (diff)

comment:4 Changed 2 weeks ago by Antoine Martin

Resolution: invalid
Status: reopenedclosed

Please do not re-open this ticket and complain to your distributor instead.
The xpra package they provide is not configured properly.

python2-websockify-client

No idea what the correct package name is, but this probably is not it.
(it is a library we use for providing server support, not client)

comment:5 Changed 2 weeks ago by SpaceboyRoss

I found out my distro only provides websockify for python 3.7 so xpra should move to 3.7 for better support.

comment:6 Changed 2 weeks ago by Antoine Martin

I found out my distro only provides websockify for python 3.7 so xpra should move to 3.7 for better support.

Again, this has nothing to do with the xpra project.
xpra supports python 3.7 just fine (#1878), if the archlinux package does not then complain there not here.

Last edited 2 weeks ago by Antoine Martin (previous) (diff)
Note: See TracTickets for help on using tickets.