xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 4 months ago

Last modified 3 months ago

#2084 closed defect (wontfix)

clicking on the task manager window icon does not minimize

Reported by: heenwu Owned by: heenwu
Priority: major Milestone: 2.5
Component: client Version: 2.4.x
Keywords: Cc: Antoine Martin

Description

client: win7
server: rhel7.4
Clicking on the window icon which is gedit application remoted from rhel7.4 cannot be minimized .

Change History (9)

comment:1 Changed 5 months ago by Antoine Martin

Owner: changed from Antoine Martin to heenwu

I'm not sure I understand where you're clicking, can you include a screenshot?

Please also specify the specific xpra version you are using at both ends. (as per wiki/ReportingBugs)

Last edited 5 months ago by Antoine Martin (previous) (diff)

comment:2 in reply to:  1 Changed 5 months ago by heenwu

Xpra version is 2.3.4.Cannot include screenshot. I clicked the application of gedit on win7 task manager,which remoted from rhel7.4, but no minimized. I discovered this problem just on the gedit of rhel7.4.

Last edited 5 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 5 months ago by Antoine Martin

Summary: Clicking on the window icon cannot be minimizedclicking on the task manager window icon does not minimize

OK, so we're talking about the task manager icon, that's a bit clearer now.

version at both ends

Xpra version is 2.3.4.

Is that at both ends?

Why is this not running the latest supported version? (2.4.2 right now)

Please post the client log by adding -d metadata to the command line.

comment:4 Changed 5 months ago by heenwu

I changed the version to 2.4.2, but this problem still exist. client log adding -d metadata as follow:

2018-12-20 14:46:47,825 process_new_common: [1, 100, 100, 1269, 811, {'size-constraints': {'minimum-size': (474, 130), 'gravity': 1, 'base-size': (0, 0)}, 'client-machine': 'rhel161', 'pid': 13288, 'group-leader-xid': 10485761, 'sticky': False, 'fullscreen': False, 'xid': '0xa000f8', 'title': 'Untitled Document 1 - gedit', 'icon-title': 'Untitled Document 1 - gedit', 'role': 'gedit-window-1545287439-846033-0-rhel161', 'above': False, 'maximized': False, 'class-instance': ('gedit', 'Gedit'), 'skip-pager': False, 'opacity': -1, 'decorations': 0, 'iconic': False, 'window-type': ('NORMAL',), 'skip-taskbar': False, 'below': False, 'command': '', 'modal': False}], metadata={'size-constraints': {'minimum-size': (474, 130), 'gravity': 1, 'base-size': (0, 0)}, 'opacity': -1, 'iconic': False, 'decorations': 0, 'client-machine': 'rhel161', 'pid': 13288, 'group-leader-xid': 10485761, 'sticky': False, 'modal': False, 'window-type': ('NORMAL',), 'skip-taskbar': False, 'fullscreen': False, 'xid': '0xa000f8', 'title': 'Untitled Document 1 - gedit', 'icon-title': 'Untitled Document 1 - gedit', 'below': False, 'role': 'gedit-window-1545287439-846033-0-rhel161', 'above': False, 'maximized': False, 'command': '', 'class-instance': ('gedit', 'Gedit'), 'skip-pager': False}, OR=False
2018-12-20 14:46:47,826 popup_types(['NORMAL'])=()
2018-12-20 14:46:47,827 set_alpha() has_alpha=False, <class 'xpra.client.gl.gtk2.gl_window_backing.GLPixmapBacking'>.HAS_ALPHA=False, realized=False
2018-12-20 14:46:47,833 update_metadata({'size-constraints': {'minimum-size': (474, 130), 'gravity': 1, 'base-size': (0, 0)}, 'opacity': -1, 'iconic': False, 'decorations': 0, 'client-machine': 'rhel161', 'pid': 13288, 'group-leader-xid': 10485761, 'sticky': False, 'modal': False, 'window-type': ('NORMAL',), 'skip-taskbar': False, 'fullscreen': False, 'xid': '0xa000f8', 'title': 'Untitled Document 1 - gedit', 'icon-title': 'Untitled Document 1 - gedit', 'below': False, 'role': 'gedit-window-1545287439-846033-0-rhel161', 'above': False, 'maximized': False, 'command': '', 'class-instance': ('gedit', 'Gedit'), 'skip-pager': False})
2018-12-20 14:46:47,833 set_metadata({'size-constraints': {'minimum-size': (474, 130), 'gravity': 1, 'base-size': (0, 0)}, 'opacity': -1, 'iconic': False, 'decorations': 0, 'client-machine': 'rhel161', 'pid': 13288, 'group-leader-xid': 10485761, 'sticky': False, 'modal': False, 'window-type': ('NORMAL',), 'skip-taskbar': False, 'fullscreen': False, 'xid': '0xa000f8', 'title': 'Untitled Document 1 - gedit', 'icon-title': 'Untitled Document 1 - gedit', 'below': False, 'role': 'gedit-window-1545287439-846033-0-rhel161', 'above': False, 'maximized': False, 'command': '', 'class-instance': ('gedit', 'Gedit'), 'skip-pager': False})
2018-12-20 14:46:56,983 metadata update for window 1: {'iconic': True}
2018-12-20 14:46:56,984 update_metadata({'iconic': True})
2018-12-20 14:46:56,984 set_metadata({'iconic': True})
2018-12-20 14:46:58,649 metadata update for window 1: {'iconic': False}
2018-12-20 14:46:58,650 update_metadata({'iconic': False})
2018-12-20 14:46:58,650 set_metadata({'iconic': False})
2018-12-20 14:47:01,720 metadata update for window 1: {'iconic': True}
2018-12-20 14:47:01,720 update_metadata({'iconic': True})
2018-12-20 14:47:01,721 set_metadata({'iconic': True})
2018-12-20 14:47:03,030 metadata update for window 1: {'iconic': False}
2018-12-20 14:47:03,030 update_metadata({'iconic': False})
2018-12-20 14:47:03,031 set_metadata({'iconic': False})
2018-12-20 14:47:04,697 metadata update for window 1: {'iconic': True}
2018-12-20 14:47:04,697 update_metadata({'iconic': True})
2018-12-20 14:47:04,697 set_metadata({'iconic': True})
2018-12-20 14:47:06,082 metadata update for window 1: {'iconic': False}
2018-12-20 14:47:06,082 update_metadata({'iconic': False})
2018-12-20 14:47:06,082 set_metadata({'iconic': False})
2018-12-20 14:47:08,748 metadata update for window 1: {'iconic': True}
2018-12-20 14:47:08,749 update_metadata({'iconic': True})
2018-12-20 14:47:08,749 set_metadata({'iconic': True})
2018-12-20 14:47:10,132 metadata update for window 1: {'iconic': False}
2018-12-20 14:47:10,132 update_metadata({'iconic': False})
2018-12-20 14:47:10,132 set_metadata({'iconic': False})
2018-12-20 14:47:25,798 metadata update for window 1: {'iconic': True}
2018-12-20 14:47:25,799 update_metadata({'iconic': True})
2018-12-20 14:47:25,799 set_metadata({'iconic': True})
2018-12-20 14:47:26,979 metadata update for window 1: {'iconic': False}
2018-12-20 14:47:26,979 update_metadata({'iconic': False})
2018-12-20 14:47:26,979 set_metadata({'iconic': False})
Last edited 5 months ago by Antoine Martin (previous) (diff)

comment:5 Changed 5 months ago by heenwu

It seems to not trigger minimized event when I clicked the icon of gedit from task manager, but clicking the gedit minimization button can minimize.

comment:6 Changed 5 months ago by heenwu

I find that the gedit remoted from rhel7.4 is without border, so the window stytle cannot include "WS_MINIMIZEBOX".

comment:7 Changed 5 months ago by Antoine Martin

I can reproduce this with any recent server OS. This looks like a "feature" of those newer gnome applications with CSD.
Client-Side-Decoration strikes again: by moving the responsibility for drawing the window controls and the title bar to the client application, they make it much more difficult to remote those applications when there isn't the same set of features available the operating system we remote to.

I'm really not sure how to solve this: forcing the window border would make it really ugly as the window would then have two title bars with the two sets of minimize and maximize buttons...

Unless you can suggest another solution, I will probably close this as 'wontfix'.

comment:8 Changed 4 months ago by Antoine Martin

Resolution: wontfix
Status: newclosed

Nothing we can do. It's a gnome feature.

comment:9 Changed 3 months ago by Antoine Martin

Note: there is a project called gtk3-nocsd which removes CSD - this may work for you.
Just be aware that Debian / Ubuntu packaged it wrong so it can cause crashes: #1981.

Note: See TracTickets for help on using tickets.