xpra icon
Bug tracker and wiki

Opened 8 months ago

Closed 5 months ago

Last modified 5 weeks ago

#2095 closed defect (worksforme)

Existing local printers deleted on server exit

Reported by: tc424 Owned by: tc424
Priority: critical Milestone: 2.5
Component: printing Version: 2.4.x
Keywords: Cc:

Description

Under certain circumstances, all existing local printers are deleted by xpra on server shutdown. It appears to be local connections which trigger it.

Version: 2.4-r20681-1

Attachments (2)

xpra-print.log (32.1 KB) - added by tc424 8 months ago.
Log file of session in which printers get deleted
xpra-bug.zip (351.0 KB) - added by tc424 8 months ago.
Xpra bug tool output

Download all attachments as: .zip

Change History (8)

Changed 8 months ago by tc424

Attachment: xpra-print.log added

Log file of session in which printers get deleted

Changed 8 months ago by tc424

Attachment: xpra-bug.zip added

Xpra bug tool output

comment:1 Changed 8 months ago by Antoine Martin

Priority: majorcritical
Status: newassigned

We should do a number of things here:

  • detect when the environment is the 100% identical and skip printer forwarding - this only shows up once in your log, if all the connections were local then this should be every time:
    local client with identical machine id,
     not configuring local printers
    

This is a per-connection check, but maybe we're somehow getting it mixed up?

  • if a printer with the exact same name already exists, either don't add it or re-add under a different name?
  • detect when adding a printer has failed - those commands trying to re-add must have failed? (we already do check the lpadmin command's exit code..)

Maybe this is a race condition since we exec lpadmin asynchronously?

@tc424: can you clarify which machine is meant to have which printers exported?

  • server is Ubuntu 16.04
  • you are connecting via ssh?
  • one of the clients is running Ubuntu 18.04?
  • Canon-MG3600 is local?

comment:2 Changed 8 months ago by tc424

Ah, yes, just realised there were two parts to that session.. I'll try to clarify.

Yes, server ("xubuntu") is 16.04. It has connections to a Canon MG3150 and an MX475.

I initially connected from my netbook ("asus") which probably has a connection to my neighbour's Canon MG3600. That would have been an ssh connection.

Then I connected locally from xubuntu itself, which I think may be where it all went wrong..

comment:3 Changed 6 months ago by Antoine Martin

Owner: changed from Antoine Martin to tc424
Status: assignednew

Not sure why it took me so long to fix it, but rtc424 should do the trick.

comment:4 Changed 5 months ago by Antoine Martin

Resolution: worksforme
Status: newclosed

comment:5 Changed 5 months ago by Antoine Martin

Caused a regression: #2267

comment:6 Changed 5 weeks ago by Antoine Martin

See also #930 (older ticket with similar issue)

Note: See TracTickets for help on using tickets.