xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

#2098 closed defect (fixed)

Address family not supported by protocol connection error

Reported by: J. Max Mena Owned by: Antoine Martin
Priority: blocker Milestone: 2.5
Component: client Version: trunk
Keywords: Cc:

Description

Currently running trunk r21278 on a Fedora 28 server and trying to connect with another trunk r21278 Fedora 28 machine as a client.

Attempting to connect using xpra attach ssh:user@host or xpra attach tcp:ip:port or xpra attach ssh:host (which works for me because my user is the same on the client and server) fails with the following error:

xpra initialization error:
 connection failed: [Errno 97] Address family not supported by protocol

Rolling my server back to r21275 fixes it, and a quick bisection shows that r21276 is where the issue appears for me.

Change History (5)

comment:1 Changed 3 months ago by Antoine Martin

Owner: changed from Antoine Martin to J. Max Mena

That's caused by #2092.
Odd, because without r21277 the default behaviour was meant to be unchanged.

Please post the output of (changing the value of HOSTNAME):

python -c "import socket;print(socket.getaddrinfo('HOSTNAME', 10000, 0, socket.SOCK_STREAM))"

comment:2 Changed 3 months ago by Antoine Martin

Summary: Unable to connect on latest TrunkAddress family not supported by protocol connection error

comment:3 Changed 3 months ago by J. Max Mena

Owner: changed from J. Max Mena to Antoine Martin

Requested output:

[max@verschlimmbessern ~] $ python -c "import socket;print(socket.getaddrinfo('vorfuehreffekt', 10000, 0, socket.SOCK_STREAM))"
[(10, 1, 6, '', ('2600:1700:65a0:3470:93af:da92:db2b:6cbd', 10000, 0, 0)), (2, 1, 6, '', ('192.168.1.81', 10000))]

Looks like a valid and correct IPV4 address, and the IPV6 address looks correct, but I'm not familiar enough with them to be sure.

Last edited 3 months ago by J. Max Mena (previous) (diff)

comment:4 Changed 3 months ago by J. Max Mena

I forgot to post an IPV4 address, but it looks correct as well:

[max@verschlimmbessern ~] $ python -c "import socket;print(socket.getaddrinfo('192.168.1.81', 10000, 0, socket.SOCK_STREAM))"
[(2, 1, 6, '', ('192.168.1.81', 10000))]

comment:5 Changed 3 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Fixed in r21279 + r21280 + r21281 (docstring)

Note: See TracTickets for help on using tickets.