xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 5 months ago

#2106 closed defect (fixed)

Xpra installation error in CentOS6

Reported by: Kleber Santana Owned by: Kleber Santana
Priority: major Milestone: 2.5
Component: platforms Version: 1.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

I am trying to install xpra in centos6, however it is returning this error:

# yum install xpra
...
...
---> Package lz4.x86_64 0:1.8.0-1.el6_9 will be installed
---> Package xpra.x86_64 0:1.0.12-2.r19800.el6_9 will be installed
--> Processing Dependency: libx264.so.148()(64bit) for package: xpra-1.0.12-2.r19800.el6_9.x86_64
--> Finished Dependency Resolution
Error: Package: xpra-1.0.12-2.r19800.el6_9.x86_64 (xpra-el6-x86_64)
           Requires: libx264.so.148()(64bit)
           Available: x264-xpra-20170704-1.el6_9.x86_64 (xpra-el6-x86_64)
               libx264.so.148()(64bit)
           Available: x264-xpra-20170704-1.el6_10.x86_64 (xpra-el6-x86_64)
               libx264.so.148()(64bit)
           Installing: x264-xpra-20190109-1.el6_10.x86_64 (xpra-el6-x86_64)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The spacewalk repository is "linked" with http://xpra.org/dists/CentOS/6/x86_64/
Any ideas? Regards.

Change History (7)

comment:1 Changed 5 months ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Kleber Santana

Please try again, centos 6.10 came out after xpra 1.0.12 so a rebuild was needed.
Now that xpra 1.0.13 is out, the problem should not occur.

Note: there are no el6_9 tags in any of the centos 6.10 packages.
If you are installing and not updating, then maybe you need to force a repository refresh: yum clean all will do the trick.

Please close the ticket if that works for you.

comment:2 Changed 5 months ago by Kleber Santana

Hi Martin,

I updated my host 6_10. Installing:

yum install xpra fail. Error:

---> Package xpra-common.noarch 0:1.0.13-1.r21370.el6_10 will be installed
--> Finished Dependency Resolution
Error: Package: ffmpeg-xpra-4.1-2.el6_10.x86_64 (xpra-el6-x86_64)
           Requires: libx264.so.148()(64bit)
           Available: x264-xpra-20151202-1.el6.x86_64 (xpra-el6-x86_64)
               libx264.so.148()(64bit)
           Available: x264-xpra-20160205-1.el6_6.x86_64 (xpra-el6-x86_64)
               libx264.so.148()(64bit)
           Available: x264-xpra-20160205-1.el6_7.x86_64 (xpra-el6-x86_64)

Kleber

Last edited 5 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 5 months ago by Kleber Santana

Martin,

I think that the package ffmpeg-xpra-4.1-2.el6_10.x86_64 asks for libx264.so.148 ... but it depends on the package x264-xpra whose version that is tied as dependency has in it the version libx264.so.155 of lib. So, the error in the installation.

regards,

Kleber

comment:4 Changed 5 months ago by Antoine Martin

I've rebuilt ffmpeg-xpra against the correct version of x264-xpra, try:

yum clean all
yum install xpra

comment:5 Changed 5 months ago by Wilhelm de Araujo Rodrigues

Version: 2.4.x1.0.x

I removed all packages from xpra and installed the following specific versions of the following packages:

yum remove xorg-x11-drv-dummy-0.3.8-1.xpra1.el6_10.x86_64 xpra-common-1.0.12-2.r19800.el6_9.noarch python2-rencode-1.0.6-1.xpra1.el6_10.x86_64 x264-xpra-20170704-1.el6_8.x86_64 python2-pyopengl-3.1.1a1-10xpra1.el6_10.x86_64 libvpx-xpra-1.7.0-1.el6_10.x86_64
yum --setopt=obsoletes=0 install -y x264-xpra-20170704-1.el6_8.x86_64 ; yum --setopt=obsoletes=0 install -y xpra-1.0.12-1.r19858.el6_10.x86_64

This works for xpra-1.0.12.

When trying to update to version xpra-1.0.13, dependency chain is broken like kleber said.
Update asks for libx264.so.148, which is not available, because the update installs x264-xpra-20190109-1.el6_8.x86_64, who has libx264.so.155.

x264-xpra-20190109-1.el6_8.x86_64 : x264 library for xpra
Repo        : xpra-el6-x86_64
Matched from:
Filename    : /usr/lib64/xpra/libx264.so.155
Last edited 5 months ago by Antoine Martin (previous) (diff)

comment:6 Changed 5 months ago by Kleber Santana

It's ok now.

Thanks!

Kleber

comment:7 Changed 5 months ago by Kleber Santana

Resolution: fixed
Status: newclosed

OK.

Note: See TracTickets for help on using tickets.