xpra icon
Bug tracker and wiki

Opened 8 months ago

Closed 6 weeks ago

Last modified 6 weeks ago

#2112 closed defect (fixed)

Automated Tests missing data

Reported by: J. Max Mena Owned by: Smo
Priority: major Milestone: 2.5
Component: tests Version: trunk
Keywords: Cc:

Description

As mentioned in #619, #1840, and #2064, the automated tests are missing a handful of data points. From ticket:1840#comment:6, most of the useful data points such as batch delay, quality, et al aren't included in the CSV. As far as I can tell, there's no error or traceback printed when the tests run xpra info, so it's likely that the Xpra Info page has changed, as is mentioned. The test code will likely need to be updated to reflect these changes.

Attachments (1)

test.csv (3.4 KB) - added by Smo 7 weeks ago.
tests data from browser test

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 months ago by Antoine Martin

Status: newassigned

I'm pretty sure the data collection breakage is fairly recent, whereas these tickets are not, so you should be able to test the version they were completed for:

  • #619 was completed for 2.3
  • #1840 was completed for 2.4

comment:2 Changed 7 months ago by Antoine Martin

Wow, this whole thing is in terrible shape.
Minor cleanup in r21958.
Bug fix in r21959. Now at least some of the tests do run.

Now the real problem with the missing data is the same thing that required fixes to the session info dialog (r21340).

As of r21960, we capture the batch delay again, more fixes needed.

comment:3 Changed 7 months ago by Antoine Martin

As of r21962, the actual batch delay is back (but now this is a normalized value... and maybe this should not be compared?), as well as the latency values.

Still need to restore:

  • packets/s in and out
  • application packets/s
  • speed and quality

comment:4 Changed 7 months ago by Antoine Martin

  • r21996 fixes the packet counters
  • r21997 fixes speed and quality data collection

comment:5 Changed 7 months ago by Antoine Martin

Owner: changed from Antoine Martin to Jonathan Anthony
Status: assignednew

r21998 reverts some of the "actual batch delay" changes from r21960 + r21962 so that the values will be more in line with older versions.

Should now be usable again and the data should make sense.

comment:6 Changed 7 weeks ago by Smo

Owner: changed from Jonathan Anthony to Smo

Changed 7 weeks ago by Smo

Attachment: test.csv added

tests data from browser test

comment:7 Changed 7 weeks ago by Smo

I attached some data from some browser tests. Still seems to be some missing data points.

download limit (KB), upload limit (KB), latency (ms) all read 0 for example

Can you take a look and let me know?

comment:8 Changed 7 weeks ago by Smo

Owner: changed from Smo to Antoine Martin

comment:9 Changed 7 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to Smo

Still seems to be some missing data points.
download limit (KB), upload limit (KB), latency (ms) all read 0 for example

Those are test configuration options for trickle.
They should be showing up if you enable it.

Last edited 7 weeks ago by Antoine Martin (previous) (diff)

comment:10 Changed 6 weeks ago by Smo

Resolution: fixed
Status: newclosed

Confirmed the missing data does show up when you turn on the trickle options.

Last edited 6 weeks ago by Smo (previous) (diff)
Note: See TracTickets for help on using tickets.