xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 6 years ago

#212 closed enhancement (fixed)

honour window movements

Reported by: Antoine Martin Owned by: alas
Priority: minor Milestone: 0.12
Component: core Version: trunk
Keywords: Cc: daemon-pnz@…

Description (last modified by Antoine Martin)

since r1089 we honour client triggered window resizes (see #107), we should probably also honour client window movements.
Unfortunately this is more tricky... see #158

Problems:

  • avoid loops, the client will send a configure event when the window is moved... which can trigger another move, etc..
  • as per #170: there are small offsets to do with window borders - this needs sorting out too
  • too many places where the same information is kept, making it difficult to synchronize everything - maybe more of it should be derived/calculated rather than stored?

Attachments (2)

honour-window-move.patch (3.6 KB) - added by Antoine Martin 7 years ago.
if we find that the client window has moved, move our corral window and pass it on to the client
honour-window-movep2.patch (4.0 KB) - added by Antoine Martin 7 years ago.
missing bits from the first patch

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by Antoine Martin

Attachment: honour-window-move.patch added

if we find that the client window has moved, move our corral window and pass it on to the client

comment:1 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Status: newaccepted

Changed 7 years ago by Antoine Martin

Attachment: honour-window-movep2.patch added

missing bits from the first patch

comment:2 Changed 7 years ago by daemonpnz

Cc: daemon-pnz@… added

comment:3 Changed 7 years ago by Antoine Martin

Milestone: 0.9future

re-scheduling for a later version

comment:4 Changed 6 years ago by Antoine Martin

Milestone: future0.12

0.12 should deal with focus/move issues

comment:5 Changed 6 years ago by Antoine Martin

Status: acceptednew

Many changes in this area because of #532, and window moves now done in r5811.

Please check on a variety of platforms using the test applications:

Especially with tricksy setups like multi-monitor: when the windows are on the secondary one (to make sure the coordinates used for the calculations are absolute and not relative to whatever screen you are on)

And maybe also check for regressions in fullscreen/maximize/etc (just in case):

etc.

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:6 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

comment:7 Changed 6 years ago by alas

  • test_window_move - on osx this seems to work as expected, but on windows the move me button doesn't move the window - though if moved manually, the location is output in the xterm from which the process is spawned.
  • test_window_resize - seems to work as expected, osx and windows (though the fast resize is not really very fast at all on osx).
  • test_window_mapresize - on both osx and windows it seems to work as expected, but after ~ 8 seconds the window closes (whether any resizing has been done or not) ... coordinates do not seem to be relative to the screen, but rather relative to the total display size.
  • test_window_maximize - this seems to work as expected, on a single window osx or multi-window windows set up, though the unmaximize me button doesn't work, which is easily worked around by using the unmaximize button supplied by the OS.
Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:8 Changed 6 years ago by Antoine Martin

  • move: I am unable to reproduce the problem on win32, what revision are you testing with? can you post the client and server log with "-d window" (include only the relevant section)
  • resize: fast_resize may well behave differently on different platforms, depending on how quickly they respond to our request to resize the window (more slowly on OSX it seems). As long as things end up looking OK, we're good.
  • mapresize: it was meant to close after 10 seconds, I've changed it in r5851
  • maximize: that's a bug: #537

comment:9 Changed 6 years ago by alas

I think the version was the issue with the test_window_move - I was using r5444.

Testing again with r5828 the move me button causes the window to "hop" as expected.

This looks like it should all be good. (I assume you no longer need the client and server logs?)

comment:10 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Done!

Note: See TracTickets for help on using tickets.