xpra icon
Bug tracker and wiki

Opened 2 weeks ago

Closed 12 days ago

Last modified 11 days ago

#2140 closed defect (fixed)

Window icon not updating on client

Reported by: Mark Harkin Owned by: Antoine Martin
Priority: minor Milestone: 2.5
Component: server Version: 2.4.x
Keywords: Cc:

Description

Server (Alpine or CentOS) on r21585
Client (Windows 10) Python or html on r21585

To reproduce the simplest setup is to start a server with --start-child=xterm
Login from a client(html or python) and from the created xterm window run xterm to create another xterm window. This new window doesn't have the correct icon. Disconnecting and reconnect xpra causes the icon show correctly.

Also happening from a client on older code so appears to be a server side issue, introduced within the last few months.

From server with "-d icon"

2019-02-07 19:09:58,148 _NET_WM_ICON_NAME=None
2019-02-07 19:09:58,148 WM_ICON_NAME=xterm
2019-02-07 19:09:58,149 _NET_WM_ICON changed on 0xa0000d, re-reading
2019-02-07 19:09:58,149 icon is now None, pixmap=None
2019-02-07 19:09:58,152 client icon settings: size=(64, 64), max_size=(128, 128)
2019-02-07 19:09:58,154 send_window_icon window WindowModel(0xa0000d) icon=None
2019-02-07 19:09:58,154 get_default_window_icon() using ('xterm', 'XTerm')
2019-02-07 19:09:58,154 <gtk.IconTheme object at 0x7ff11245e8c0 (GtkIconTheme at 0x55b4d5b0ddf0)>.lookup_icon(xterm-color)=None
2019-02-07 19:09:58,154 <gtk.IconTheme object at 0x7ff11245e8c0 (GtkIconTheme at 0x55b4d5b0ddf0)>.lookup_icon(xterm)=None
2019-02-07 19:09:58,154 <gtk.IconTheme object at 0x7ff11245e8c0 (GtkIconTheme at 0x55b4d5b0ddf0)>.lookup_icon(xterm_48x48)=<GtkIconInfo at 0x55b4d59cca40>
2019-02-07 19:09:58,155 <GtkIconInfo at 0x55b4d59cca40>.load_icon()=<gtk.gdk.Pixbuf object at 0x7ff11245e910 (GdkPixbuf at 0x55b4d59cd300)>
2019-02-07 19:09:58,155 get_default_window_icon()=<cairo.ImageSurface object at 0x7ff1134293b0>
2019-02-07 19:09:58,155 send_window_icon window WindowModel(0xa0000d) using default window icon=<cairo.ImageSurface object at 0x7ff1134293b0>
2019-02-07 19:09:58,155 send_window_icon() window=WindowModel(0xa0000d), wid=6, compression scheduled in 876200670ms
2019-02-07 19:09:58,158 client @21.702 reset_icon() current icon=None
2019-02-07 19:09:58,161 client @21.702 reset_icon() current icon=None

Change History (2)

comment:1 Changed 12 days ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks for reporting that.
This was caused by some changes for #2022 / #2090 - looks like I need to revisit that.
The fix for the window icon is in r21617: we won't wait more than a second to send it, no matter how high the batch delay value is.

comment:2 Changed 11 days ago by Mark Harkin

r21617 working as expected, thanks.

Note: See TracTickets for help on using tickets.