xpra icon
Bug tracker and wiki

Opened 11 days ago

Closed 10 days ago

Last modified 10 days ago

#2144 closed defect (fixed)

Cannot find icon None + missing icons from notification and right click menu

Reported by: stdedos Owned by: Antoine Martin
Priority: minor Milestone: 2.5
Component: client Version: 2.4.x
Keywords: Cc:

Description

Xpra run as client, Win10, Xpra-Python3-x86_64_Setup_2.5-r21642

2019-02-12 19:27:20,492 Xpra GTK3 client version 2.5-r21642 64-bit
2019-02-12 19:27:20,496  running on Microsoft Windows 10
2019-02-12 19:27:21,313 GStreamer version 1.14.4 for Python 3.7.2 64-bit
2019-02-12 19:27:22,004  keyboard settings: layout=us
2019-02-12 19:27:22,006  desktop size is 1600x900 with 1 screen:
2019-02-12 19:27:22,006   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2019-02-12 19:27:22,006     (Standard monitor types) Generic PnP Monitor (309x174 mm - DPI: 131x131)
'C:\Program Files\Xpra\lib\gio\modules\libgiolibproxy.dll': The specified module could not be found.
Failed to load module: C:\Program Files\Xpra\lib\gio\modules\libgiolibproxy.dll
'g_io_module_load': The specified procedure could not be found.
Failed to load module: C:\Program Files\Xpra\lib\gio\modules\libproxy-1.dll
2019-02-12 19:27:24,364 unknown string message: 0xc1d2 / 0x0 / 0x0
2019-02-12 19:27:25,278 Error: cannot find icon 'None'
2019-02-12 19:27:35,594 enabled remote logging
2019-02-12 19:27:37,062 Xpra GTK2 X11 server version 2.5-r21480 64-bit
2019-02-12 19:27:37,063  running on Linux Ubuntu 16.04 xenial
2019-02-12 19:28:09,159 unknown string message: 0xc0ac / 0x1 / 0x1
2019-02-12 19:28:09,288 unknown string message: 0xc0ac / 0x2 / 0x0
2019-02-12 19:28:27,575 unknown string message: 0xc0ac / 0x1 / 0x1
2019-02-12 19:28:27,667 unknown string message: 0xc0ac / 0x2 / 0x0
2019-02-12 19:28:27,695 unknown string message: 0xc0ac / 0x1 / 0x1
2019-02-12 19:28:27,803 unknown string message: 0xc0ac / 0x2 / 0x0
2019-02-12 19:29:20,631 unknown string message: 0xc0ac / 0x1 / 0x1
2019-02-12 19:29:20,785 unknown string message: 0xc0ac / 0x2 / 0x0
2019-02-12 19:31:08,967 Error: cannot find icon 'None'


Icon in the notification bar is present, but empty. Plus, the right click menu, the about menu etc have no images.

Change History (2)

comment:1 Changed 10 days ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks for pointing that out.

This was caused by the build changes for #1883, fixed in r21647.
New builds uploaded.

comment:2 Changed 10 days ago by stdedos

Verified as fixed in r21648

Note: See TracTickets for help on using tickets.