xpra icon
Bug tracker and wiki

Opened 9 months ago

Closed 8 months ago

Last modified 8 months ago

#2146 closed defect (worksforme)

window offset when maximized

Reported by: stdedos Owned by: stdedos
Priority: major Milestone: 2.5
Component: android Version: 2.4.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Win 10, Xpra-Python3-x86_64_Setup_2.5-r21648, on Ubuntu 16.04.5 server r20740

Started:

"C:\Program Files\Xpra\xpra_cmd" start ssh://user@ip/ --clipboard=no --webcam=no --speaker=off --microphone=off --opengl=no --start=gnome-terminal --start-new-commands=yes

When maximizing the window, there is some offset added from the top of the window (see attachment). However, everything else works normally. Going full screen (Shift+F11) "copies" the behavior from the window (on maximized, there is the offset; otherwise no)


Attachments (1)

Xpra_cmd_2019-02-13_14-08-07.png (12.7 KB) - added by stdedos 9 months ago.

Download all attachments as: .zip

Change History (7)

Changed 9 months ago by stdedos

comment:1 Changed 8 months ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to stdedos

I believe that what you are seeing is caused by the terminal's size-hints: terminals can only be resized in multiples of the font size and when we are forced to accommodate a size which isn't a multiple of the font size, we choose the next size down from that and add padding.

You can verify this by posting the client's -d geometry log.

comment:2 Changed 8 months ago by stdedos

I'll try to verify later. It's just weird that it started happening sometime after server:r20740 and client:py3/r21648 (but now I have no idea on the version).


Is it somehow easy that the padding is added below (and to the right, if applicable) instead of above (and left, if applicable)?


This behavior is also weird:

Going full screen (Shift+F11) "copies" the behavior from the window (on maximized, there is the offset; otherwise no)

  • Maximized --> FullScreen has padding
  • Direct to FullScreen has no padding
Version 0, edited 8 months ago by stdedos (next)

comment:3 Changed 8 months ago by Antoine Martin

I have problems with GTK3: #2214, but with GTK2 the window is padded at the bottom and to the right. There is no offset at the top.
The padding is consistent too: always the same no matter how I go fullscreen (F11 or Shift+F11), both from maximized or from a regular size.

@stdedos: what am I doing wrong? (tested with same OS versions as you, just the latest xpra 2.5 beta)

comment:4 in reply to:  3 Changed 8 months ago by stdedos

Replying to Antoine Martin:

I have problems with GTK3: #2214, but with GTK2 the window is padded at the bottom and to the right. There is no offset at the top.
The padding is consistent too: always the same no matter how I go fullscreen (F11 or Shift+F11), both from maximized or from a regular size.

@stdedos: what am I doing wrong? (tested with same OS versions as you, just the latest xpra 2.5 beta)

Interestingly, I was thinking of testing it tonight myself again, since, I also found that the window is padded bottom/right.

I am not sure who's responsible for the padding (server probably?), but it must have been fixed between r20740 and r22053+ (since I updated as soon as #2198 was fixed)

comment:5 Changed 8 months ago by Antoine Martin

Resolution: worksforme
Status: newclosed

comment:6 Changed 8 months ago by stdedos

Verified that it was "magically" fixed sometime in-between

Note: See TracTickets for help on using tickets.