xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Changes between Initial Version and Version 1 of Ticket #2174


Ignore:
Timestamp:
02/25/19 08:34:32 (2 years ago)
Author:
Antoine Martin
Comment:

This isn't related to #2153, different menu: this one is your system "start menu" definition.

That's a bug in your distribution. You can reproduce it with:

python2 -c "from xdg.Menu import parse;parse()"

On most distributions this works fine but on Ubuntu this can fail. IIRC, that's because the menu definitions point to a menu file which is missing. (further details can be obtained by running with -d menu)

They shouldn't be shipping a library that cannot be called: either the library should fail more gracefully or they should ensure that their menu definitions do not trigger the problem.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #2174

    • Property Status changed from new to closed
    • Property Resolution changed from to invalid
  • Ticket #2174 – Description

    initial v1  
    1 ''It feels related to #2153, but no idea if it is. Search https://xpra.org/trac/search returns nothing''
     1It feels related to #2153, but no idea if it is. Search returns nothing.
    22
    33