xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 4 weeks ago

Last modified 3 weeks ago

#2176 closed defect (fixed)

cannot connect to old-style shadow

Reported by: stdedos Owned by: Antoine Martin
Priority: major Milestone: 2.5
Component: server Version: 2.4.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Attaching to an XPRA_SHADOW_MULTI_WINDOW=0 xpra shadow (#1801) with:

Xpra-Client-x86_64_2.5-r21454\xpra_cmd" attach ssh://user@ip/0  --clipboard=no --opengl=no --min-quality=20 --desktop-scaling=0.75

2019-02-25 18:58:33,191 Xpra GTK2 client version 2.5-r21454 64-bit
2019-02-25 18:58:33,196  running on Microsoft Windows 10
2019-02-25 18:58:33,254 Warning: failed to import opencv:
2019-02-25 18:58:33,254  No module named cv2
2019-02-25 18:58:33,254  webcam forwarding is disabled
2019-02-25 18:58:33,987 GStreamer version 1.14.4 for Python 2.7.15 64-bit
2019-02-25 18:58:35,556  keyboard settings: layout=us
2019-02-25 18:58:35,559  desktop size is 1600x900 with 1 screen:
2019-02-25 18:58:35,560   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2019-02-25 18:58:35,560     DISPLAY1 (309x174 mm - DPI: 131x131)
2019-02-25 18:58:35,560  downscaled by 75%, virtual screen size: 2133x1200
2019-02-25 18:58:35,561   Default (423x238 mm - DPI: 128x128) workarea: 2133x1147
2019-02-25 18:58:35,561     DISPLAY1 (309x174 mm - DPI: 175x175)
2019-02-25 18:58:42,690 enabled remote logging
2019-02-25 18:58:42,695 Xpra GTK2 shadow server version 2.5-r21828 64-bit
2019-02-25 18:58:42,698  running on Linux Ubuntu 16.04 xenial

Gives:

Client:
Traceback (most recent call last):
  File "./xpra/client/gtk_base/gtk_client_base.py", line 866, in process_ui_capabilities
  File "./xpra/client/ui_client_base.py", line 432, in process_ui_capabilities
  File "./xpra/client/mixins/network_state.py", line 124, in process_ui_capabilities
  File "./xpra/client/mixins/network_state.py", line 253, in send_deflate_level
AttributeError: 'NoneType' object has no attribute 'set_compression_level'
----------------------------------------------------------------------------
Server:
2019-02-25 18:58:41,327 New unix-domain connection received on /run/user/1000/xpra/user-precision-t3620-0[0m
2019-02-25 18:58:41,332 Handshake complete; enabling connection[0m
2019-02-25 18:58:41,335 client clipboard does not include contents slice fix[0m
2019-02-25 18:58:41,336  automatic picture encoding enabled, also available:[0m
2019-02-25 18:58:41,337   png, png/P, png/L, rgb24, rgb32, jpeg[0m
2019-02-25 18:58:41,338 Python/GTK2 Microsoft Windows 10 aero client version 2.5-r21454 64-bit[0m
2019-02-25 18:58:41,338  connected from 'LT-012076' as 'user' - 'stavros.ntentos'[0m
2019-02-25 18:58:41,344 shadow server: setting default keymap translation[0m
2019-02-25 18:58:41,355  client root window size is 2133x1200[0m
[31m2019-02-25 18:58:41,363 Error: processing new connection from Protocol(unix-domain socket:/run/user/1000/xpra/user-precision-t3620-0):[0m
[31m2019-02-25 18:58:41,364  invalid property: depth[0m
2019-02-25 18:58:41,365 Disconnecting client Protocol(unix-domain socket:/run/user/1000/xpra/user-precision-t3620-0):[0m
2019-02-25 18:58:41,365  server error (error accepting new connection)[0m
2019-02-25 18:58:41,369 xpra client 4 disconnected.[0m
[31m2019-02-25 18:58:41,383 Error spawning child '"DBUS_SESSION_BUS_ADDRESS=\"$(cut -f 2- -d= /run/user/1000/dbus-session)\" gnome-screensaver-command -l"':[0m
[31m2019-02-25 18:58:41,383  [Errno 2] No such file or directory[0m
[31m2019-02-25 18:58:41,390 Error spawning child '"DBUS_SESSION_BUS_ADDRESS=\"$(cut -f 2- -d= /run/user/1000/dbus-session)\" gnome-screensaver-command -l"':[0m
[31m2019-02-25 18:58:41,390  [Errno 2] No such file or directory[0m
2019-02-25 18:58:42,076 New unix-domain connection received on /run/user/1000/xpra/user-precision-t3620-0[0m
2019-02-25 18:58:42,079 New unix-domain connection received on /run/xpra/user-precision-t3620-0[0m

Usually, it just instantly disconnects (I can see the window outline manifesting and destroyed).
It was the 3rd time client gave a different message; server is consistently.

Change History (3)

comment:1 Changed 4 weeks ago by stdedos

forgot to mention: xpra shadow remains alive to retry again and again. No idea if it matters or not

comment:2 Changed 4 weeks ago by Antoine Martin

Description: modified (diff)
Resolution: fixed
Status: newclosed

That's caused by:

[31m2019-02-25 18:58:41,364  invalid property: depth[0m

And has already been fixed in r21829.

comment:3 Changed 3 weeks ago by stdedos

Verified as fixed:

xpra GTK2 shadow version 2.5-r21899 64-bit

Microsoft Windows 10 aero client version 2.5-r21454 64-bit
`Xpra-Client-x86_64_2.5-r21454`
Note: See TracTickets for help on using tickets.