xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#2180 closed defect (fixed)

remote start does not enable video

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: critical Milestone: 2.5
Component: core Version: 2.4.x
Keywords: Cc:

Description (last modified by Antoine Martin)

xpra start ssh://localhost --start=xterm --mmap=no

Shows in the server log:

automatic picture encoding enabled, also available:
 png, png/P, png/L, webp, rgb24, rgb32, jpeg

No h264, vp8 or vp9..

The server got started by the ssh proxy as:

/bin/python3 /usr/bin/xpra start --mmap=no \
    --encodings=h264,vp9,vp8,mpeg4,mpeg4+mp4,h264+mp4,vp8+webm,vp9+webm,png,png/p,png/l,webp,rgb,rgb24,rgb32,jpeg,h265,jpeg2000,mpeg1,mpeg2 \
    --start=xterm \
    --env=XPRA_PROXY_START_UUID=5924ba14050b422d805f894f3a340fe2 \
    --daemon=yes --systemd-run=no --displayfd=5

Change History (4)

comment:1 Changed 3 months ago by Antoine Martin

Description: modified (diff)
Status: newassigned

comment:2 Changed 3 months ago by Antoine Martin

Description: modified (diff)

Blocked by #2184.

comment:3 Changed 3 months ago by Antoine Martin

I believe that this is likely caused by the threaded initialization: it is possible for the client to connect before the server's video codecs have been initialized:

    def threaded_setup(self):
        getVideoHelper().init()
        #re-init encodings now that we have video:
        self.init_encodings()

Maybe we should wait for the threaded initialization to complete before accepting clients?

comment:4 Changed 3 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Fixed in r21937 - probably too intrusive to backport.

See also #2193

Last edited 3 months ago by Antoine Martin (previous) (diff)
Note: See TracTickets for help on using tickets.