xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 2 weeks ago

#2190 closed defect (fixed)

Bionic packages do not play well with HWE 18.04

Reported by: pma Owned by: Antoine Martin
Priority: major Milestone: 2.5
Component: packaging Version: 2.4.x
Keywords: Cc:

Description

Upgraded one bionic system to HWE 18.04. XPRA was removed in upgrade process. When I tried to install it afterwards, it would have wanted to downgrade X to pre HWE state.

Change History (8)

comment:1 Changed 3 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to pma

Please post the full upgrade messages.

comment:2 Changed 3 weeks ago by pma

XPRA seems to install fine, if all needed HWE X packages are already installed in the system, but if one is missing, say xorg-video-dummy, gdebi says:

Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
Requires the REMOVAL of the following packages: xserver-xorg-core-hwe-18.04 xserver-xorg-hwe-18.04 xserver-xorg-input-all-hwe-18.04 xserver-xorg-input-libinput-hwe-18.04 xserver-xorg-input-wacom-hwe-18.04 xserver-xorg-video-all-hwe-18.04 xserver-xorg-video-amdgpu-hwe-18.04 xserver-xorg-video-ati-hwe-18.04 xserver-xorg-video-fbdev-hwe-18.04 xserver-xorg-video-intel-hwe-18.04 xserver-xorg-video-nouveau-hwe-18.04 xserver-xorg-video-qxl-hwe-18.04 xserver-xorg-video-radeon-hwe-18.04 xserver-xorg-video-vesa-hwe-18.04 xserver-xorg-video-vmware-hwe-18.04 
Requires the installation of the following packages: xserver-xorg-core xserver-xorg-video-dummy 

tool to detach/reattach running X programs
 Xpra gives you the functionality of GNU Screen for X applications.
 .
 It allows the user to view remote X applications on their local machine, and
 disconnect and reconnect from the remote machine without losing the state of
 the running applications.
 .
 Unlike VNC, these applications are "rootless".  They appear as individual
 windows inside your window manager rather than being contained within a single
 window.
Do you want to install the software package? [y/N]:

comment:3 Changed 3 weeks ago by pma

Owner: changed from pma to Antoine Martin

comment:4 Changed 3 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to pma

How are we supposed to support HWE using a single repository?

comment:5 Changed 3 weeks ago by pma

Owner: changed from pma to Antoine Martin

This seems to be the same problem: https://bugs.launchpad.net/ubuntu/+source/xpra/+bug/1691025

I tried installing from xpra repo, but the problem remained. If xorg-video-dummy is not installed, xpra wants to remove all xorg hwe packages, but if it is, it installs just fine.

comment:6 Changed 3 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

Links:

If we provide both ABIs in the repository, will apt be able to figure it out?

Last edited 3 weeks ago by Antoine Martin (previous) (diff)

comment:7 Changed 3 weeks ago by Antoine Martin

So I installed xpra stable on a fresh Ubuntu 18.04.2 installation which includes HWE by default, and everything works OK out of the box.
The only problem is that they ship a new dummy driver named xserver-xorg-video-dummy-hwe which is almost guaranteed to be missing the patches we carry.
Maybe they've messed up the package dependencies (Conflicts vs Provides attributes?)

comment:8 Changed 2 weeks ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Using debootstrap made this more difficult. Steps:

  • debootstrap a new bionic instance
  • add build-essential devscripts debhelper
  • add universe repository: echo "deb http://archive.ubuntu.com/ubuntu bionic universe" >> /etc/apt/sources.list
  • add quilt pkg-config xserver-xorg-dev x11proto-video-dev x11proto-xf86dga-dev x11proto-core-dev x11proto-fonts-dev x11proto-randr-dev x11proto-render-dev xutils-dev
  • add bionic-updates repository (this step is not documented): echo "deb http://archive.ubuntu.com/ubuntu bionic-updates main" >> /etc/apt/sources.list
  • add HWE: https://wiki.ubuntu.com/Kernel/LTSEnablementStack: sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04
  • add xorg-dev
  • rebuilt the package, and again, and again...

Through trial and error (well mostly error):


And so the official solution is now to run this command to upgrade to the HWE version (adding xserver-xorg-video-dummy-hwe-18.04):

sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04 xserver-xorg-video-dummy-hwe-18.04

That's because the Ubuntu repositories don't upgrade the dummy package during the HWE upgrade unless we tell it to. (that's an upstream bug - nothing to do with us)

The only positive thing we've gained is that we now ensure that we update the dummy package with the patched one, even when HWE is enabled.

Note: See TracTickets for help on using tickets.