xpra icon
Bug tracker and wiki

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#2198 closed defect (fixed)

org.gnome.Terminal exited with status 10

Reported by: stdedos Owned by: Antoine Martin
Priority: blocker Milestone: 2.5
Component: server Version: 2.4.x
Keywords: Cc:

Description

I am trying to verify #2172, however

Xpra-Client-x86_64_2.5-r21454\xpra_cmd start ssh://user@ip/50  --microphone=off --speaker=off --webcam=no --opengl=no --start-new-commands=yes --start=gnome-terminal

2019-02-23 19:10:49,474 Xpra GTK2 client version 2.5-r21454 64-bit
2019-02-23 19:10:49,478  running on Microsoft Windows 10
2019-02-23 19:10:50,554 GStreamer version 1.14.4 for Python 2.7.15 64-bit
2019-02-23 19:10:51,786  keyboard settings: layout=us
2019-02-23 19:10:51,790  desktop size is 1600x900 with 1 screen:
2019-02-23 19:10:51,791   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2019-02-23 19:10:51,791     DISPLAY1 (309x174 mm - DPI: 131x131)
2019-02-23 19:11:01,494 enabled remote logging
2019-02-23 19:11:01,495 Xpra GTK2 X11 server version 2.5-r21791 64-bit
2019-02-23 19:11:01,496  running on Linux Ubuntu 16.04 xenial

========

2019-03-08 14:46:02,857 cannot access python uinput module:
2019-03-08 14:46:02,857  No module named uinput
2019-03-08 14:46:03,118 created unix domain socket: /run/user/1000/xpra/user-precision-t3620-50
2019-03-08 14:46:03,118 created unix domain socket: /run/xpra/user-precision-t3620-50
2019-03-08 14:46:03,161 pointer device emulation using XTest
2019-03-08 14:46:03,168 serving html content from: /usr/share/xpra/www
2019-03-08 14:46:03,775 Warning: OpenGL support check failed:
2019-03-08 14:46:03,775  unknown error
2019-03-08 14:46:03,793 Warning: cannot forward notifications,
2019-03-08 14:46:03,793  the interface is already claimed
2019-03-08 14:46:03,793  if you do not have a dedicated dbus session for this xpra instance,
2019-03-08 14:46:03,793  use the 'notifications=no' option
2019-03-08 14:46:03,877 Warning: failed to load the mdns publisher
2019-03-08 14:46:03,877  No module named avahi
2019-03-08 14:46:03,878  either fix your installation or use the 'mdns=no' option
2019-03-08 14:46:03,878 xpra GTK2 X11 version 2.5-r21988 64-bit
2019-03-08 14:46:03,878  uid=1000 (user), gid=1000 (user)
2019-03-08 14:46:03,878  running with pid 11946 on Linux Ubuntu 16.04 xenial
2019-03-08 14:46:03,878  connected to X11 display :50 with 24 bit colors
2019-03-08 14:46:03,922 xpra is ready.
2019-03-08 14:46:04,713 New unix-domain connection received on /run/user/1000/xpra/user-precision-t3620-50
2019-03-08 14:46:04,934 printer forwarding enabled using postscript and pdf
2019-03-08 14:46:04,940 New unix-domain connection received on /run/user/1000/xpra/user-precision-t3620-50
2019-03-08 14:46:04,955 62.7GB of system memory
2019-03-08 14:46:04,955 New unix-domain connection received on /run/xpra/user-precision-t3620-50
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 10
2019-03-08 14:46:05,033 New unix-domain connection received on /run/user/1000/xpra/user-precision-t3620-50
2019-03-08 14:46:05,035 Handshake complete; enabling connection
2019-03-08 14:46:05,039  automatic picture encoding enabled, also available:
2019-03-08 14:46:05,039   png, png/P, png/L, rgb24, rgb32, jpeg
2019-03-08 14:46:05,040 Python/GTK2 Microsoft Windows 10 aero client version 2.5-r21877 64-bit
2019-03-08 14:46:05,040  connected from 'LT-012076' as 'user' - 'stavros.ntentos'
2019-03-08 14:46:05,068 setting key repeat rate from client: 500ms delay / 33ms interval
2019-03-08 14:46:05,070 setting keyboard layout to 'us'
2019-03-08 14:46:05,086  client root window size is 1600x900 with 1 display:
2019-03-08 14:46:05,086   Default (423x238 mm - DPI: 96x96) workarea: 1600x860
2019-03-08 14:46:05,086     DISPLAY1 (309x174 mm - DPI: 131x131)
2019-03-08 14:46:05,598 server virtual display now set to 1600x900
2019-03-08 14:46:05,611 DPI set to 96 x 96
2019-03-08 14:46:05,689 client @16.484 Xpra GTK2 X11 server version 2.5-r21988 64-bit
2019-03-08 14:46:05,733 client @16.484  running on Linux Ubuntu 16.04 xenial

And I don't / cannot get a window. The same issue happens if I try to call xterm and then gnome-terminal

https://wiki.gnome.org/Apps/Terminal/FAQ#Exit_status_10

Change History (6)

comment:1 Changed 6 months ago by Antoine Martin

Priority: majorblocker
Status: newassigned

I can reproduce the problem.

comment:2 Changed 6 months ago by Antoine Martin

How strange. I can launch gnome-terminal:

  • from xpra's xterm using: dbus-launch gnome-terminal
  • by pointing to the dbus session of my current desktop session instead of xpra's one: DBUS_SESSION_BUS_ADDRESS=... gnome-terminal
  • by starting xpra using: dbus-launch xpra --dbus-launch=no start --start=xterm (though it takes a few seconds as some accessibility settings timeout)

But not with the default xpra code, which executes dbus-launch and then exposes the bus address to all subprocesses. Why is that any different?

See also #2181

Last edited 6 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 6 months ago by stdedos

Note: Bisect between python2-xpra_2.5-20190223r21873-1 and python2-xpra_2.5-20190223r21988-1 to find the issue

comment:4 Changed 6 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Great hint!

So the problem in r21911 comes from the switch to a smaller whitelist of environment variables when launching dbus. (and it is more directly related to #2181 than I expected!)
Fixed in r22053.

comment:5 in reply to:  4 Changed 6 months ago by stdedos

I am not sure what how or what kind of testing you are doing, but it sounds something worth to be an End-to-End testing, since you set the ticket to be a blocker.
(i.e. client calling xpra_cmd start ssh://user@ip/50 --start=gnome-terminal a server)

Even if you have to test a very specific number of OS'es (e.g. WinX with Ubuntu LatestLTS)

comment:6 Changed 6 months ago by stdedos

Verified fixed in r22058

Note: See TracTickets for help on using tickets.