xpra icon
Bug tracker and wiki

Opened 13 days ago

Closed 12 days ago

#2205 closed defect (fixed)

paint errors with pixmap backend

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 2.5
Component: client Version: 2.4.x
Keywords: Cc:

Description (last modified by Antoine Martin)

2019-03-10 19:39:21,839 Error painting rgb32
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/client/window_backing_base.py", line 347, in do_paint_rgb
    success = paint_fn(img_data, x, y, width, height, rowstride, options)
  File "/usr/lib/python2.7/dist-packages/xpra/client/gtk2/pixmap_backing.py", line 160, in _do_paint_rgb32
    self._backing.draw_rgb_32_image(gc, x, y, width, height, gdk.RGB_DITHER_NONE, img_data, rowstride)
IndexError: rgb_buf is not large enough

Change History (2)

comment:1 Changed 13 days ago by Antoine Martin

Description: modified (diff)
Status: newassigned

Looks like the pixel data is in plain RGB format (no alpha), but we're erroneously claiming to send it as rgb32 / BGRX:

compress:   0.1ms for    6x13   pixels at  167,2    for wid=1     using     rgb32 with ratio  75.0%  (    0KB to     0KB), sequence    14, client_options={'rgb_format': u'BGRX'}
client @12.221 process_draw:     234    bytes for window   1, sequence       14,    6x13   at  167,2    using  rgb32 encoding with options={'rgb_format': 'BGRX'}
client @12.221 draw_region(167, 2, 6, 13, rgb32, 234 bytes, 18, {'rgb_format': 'BGRX'}, [<function record_decode_time at 0x7fa833123410>, <function after_draw_refresh at 0x7fa8187b18c0>])
client @12.221 Error painting rgb32
client @12.221 IndexError: rgb_buf is not large enough

6*13*3=234 (6x13 with 3 bytes per pixel)

comment:2 Changed 12 days ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Breakage was caused by r22033, fixed in r22058.

Note: See TracTickets for help on using tickets.