xpra icon
Bug tracker and wiki

Opened 13 days ago

Closed 6 days ago

#2207 closed defect (fixed)

clipboard compressible data attributeerror

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 2.5
Component: clipboard Version: 2.4.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Unconfirmed report:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/net/protocol.py", line 356, in _write_format_thread_loop
    self._add_packet_to_queue(*gpc())
  File "/usr/lib/python2.7/dist-packages/xpra/net/protocol.py", line 368, in _add_packet_to_queue
    chunks = self.encode(packet)
  File "/usr/lib/python2.7/dist-packages/xpra/net/protocol.py", line 526, in encode
    item = item.compress()
  File "/usr/lib/python2.7/dist-packages/xpra/client/gtk_base/gtk_client_base.py", line 1238, in compress_clipboard
    return self.compressed_wrapper(v.datatype, v.data)
AttributeError: 'int' object has no attribute 'datatype'

Version 2.5-r21480

TODO: verify that the new callback code does compress the Compressible items (force it for testing).

Change History (2)

comment:1 Changed 13 days ago by Antoine Martin

Description: modified (diff)
Status: newassigned

comment:2 Changed 6 days ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Minor improvements in r22119.

I am unable to reproduce the problem and since the version for which the problem was reported is older than r21742 (which uses a different closure code for registering the compressible data callback), I am reasonably confident that the problem is fixed.

Note: See TracTickets for help on using tickets.