xpra icon
Bug tracker and wiki

Opened 4 months ago

Closed 4 months ago

#2314 closed defect (fixed)

Seeing Python 3.7 Traceback in xpra v3.0-r22819

Reported by: zaveri Owned by: Antoine Martin
Priority: major Milestone: 3.0
Component: server Version: trunk
Keywords: Cc:

Description

Installing from Beta repo when launching the server.

Performing dnf update
XPRA Version installed xpra v3.0-r22819
Start Command

xpra --no-daemon --bind-tcp=0.0.0.0:12000 --start=xterm start :10

Seeing the below tracebacks on start

2019-06-03 15:38:07,295 created unix domain socket: /run/user/1000/xpra/localhost.localdomain-12
2019-06-03 15:38:07,295 cannot create group socket '/run/xpra/localhost.localdomain-12'
2019-06-03 15:38:07,295  [Errno 13] Permission denied
2019-06-03 15:38:07,333 pointer device emulation using XTest
2019-06-03 15:38:07,376 serving html content from: /usr/share/xpra/www
2019-06-03 15:38:07,853 OpenGL is supported on display ':12'
2019-06-03 15:38:07,889 D-Bus notification forwarding is available
2019-06-03 15:38:07,948 Warning: webcam forwarding is disabled
2019-06-03 15:38:07,948  the virtual video directory '/sys/devices/virtual/video4linux' was not found
2019-06-03 15:38:07,949  make sure that the 'v4l2loopback' kernel module is installed and loaded
2019-06-03 15:38:07,949 found 0 virtual video devices for webcam forwarding
2019-06-03 15:38:07,957 pulseaudio server started with pid 6965
2019-06-03 15:38:07,957  private server socket path:
2019-06-03 15:38:07,957  '/run/user/1000/xpra/pulse-12/pulse/native'
2019-06-03 15:38:08,247 GStreamer version 1.16.0 for Python 3.7.3 64-bit

(Xpra:6585): Gtk-CRITICAL **: 15:38:08.269: gtk_widget_realize: assertion 'widget->priv->anchored || GTK_IS_INVISIBLE (widget)' failed
2019-06-03 15:38:08,273 Warning: cannot use application menu data:
2019-06-03 15:38:08,273  no python-xdg module
2019-06-03 15:38:08,283 xpra GTK3 X11 version 3.0-r22819 64-bit
2019-06-03 15:38:08,283  uid=1000 (maint), gid=1000 (maint)
2019-06-03 15:38:08,283  running with pid 6585 on Linux Fedora 30 Thirty
2019-06-03 15:38:08,285  connected to X11 display :12 with 24 bit colors

** (Xpra:6585): WARNING **: 15:38:08.288: AT-SPI: Could not obtain desktop path or name


** (Xpra:6585): WARNING **: 15:38:08.292: atk-bridge: GetRegisteredEvents returned message with unknown signature

** (Xpra:6585): WARNING **: 15:38:08.292: atk-bridge: get_device_events_reply: unknown signature

** (Xpra:6585): WARNING **: 15:38:08.292: atk-bridge: get_device_events_reply: unknown signature
2019-06-03 15:38:08,299 xpra is ready.
2019-06-03 15:38:14,782 printer forwarding enabled using postscript and pdf
2019-06-03 15:38:14,785 Warning: cannot watch for application menu changes without pyinotify:
2019-06-03 15:38:14,786  No module named 'pyinotify'
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib64/python3.7/threading.py", line 917, in _bootstrap_inner
    self.run()
  File "/usr/lib64/python3.7/threading.py", line 865, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.7/site-packages/xpra/server/server_base.py", line 162, in threaded_init
    c.threaded_setup(self)
  File "/usr/lib64/python3.7/site-packages/xpra/server/mixins/child_command_server.py", line 86, in threaded_setup
    self.watch_manager = pyinotify.WatchManager()
UnboundLocalError: local variable 'pyinotify' referenced before assignment

Change History (1)

comment:1 Changed 4 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks, fixed in r22849. (trivial)

This was caused by the changes in #2310.

You can also install python3-inotify, now recommended by the RPM as of r22850.

Note: See TracTickets for help on using tickets.