xpra icon
Bug tracker and wiki

Opened 18 months ago

Closed 18 months ago

Last modified 15 months ago

#2332 closed defect (invalid)

fedora 30 mate spin server sigint kills the VM's X11

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: critical Milestone: 3.0
Component: platforms Version: 2.5.x
Keywords: Cc:

Description

Discovered during testing for #2298.

Simply start an xpra server in a GUI terminal then control-C it or use xpra stop.
The X11 server goes to a black terminal screen without a login prompt. (the actual X11 server process still seems to be running)

Using xpra exit, which leaves the vfb running, does not cause any problems. So it looks like something X11, vt or dbus related is taken down on exit.

This does not occur with the regular fedora spin.

Change History (2)

comment:1 Changed 18 months ago by Antoine Martin

Resolution: invalid
Status: newclosed

I can start N number of xpra sessions, only stopping the first one kills the desktop.

This is now confirmed as a mate bug.
I can kill the current desktop session just by running this command then killing it with a control-C:

/usr/libexec/Xorg -config /etc/xpra/xorg.conf :20

comment:2 Changed 15 months ago by Antoine Martin

See also: #1032, in particular ticket:1032#comment:15

Note: See TracTickets for help on using tickets.