xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#2333 closed defect (fixed)

Missing package

Reported by: miranska Owned by: Antoine Martin
Priority: major Milestone: 3.0
Component: android Version: 2.5.x
Keywords: Cc:

Description

There seems to be a regression related to missing package in the latest version of xpra on MacOS. If I install Xpra-x86_64-2.4.3-r21365, it starts fine. However, if I try to install Xpra-x86_64-2.5.2-r22874 it gives the following error:

> xpra
2019-06-15 10:58:26,566 Error: gtkosx_application module is missing - trying to continue anyway
xpra main error:
Traceback (most recent call last):
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/scripts/main.py", line 97, in main
    return run_mode(script_file, err, options, args, mode, defaults)
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/scripts/main.py", line 453, in run_mode
    from xpra.gtk_common.gui import main as gui_main        #@Reimport
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/gtk_common/gui.py", line 15, in <module>
    from xpra.gtk_common.gtk_util import (
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/gtk_common/gtk_util.py", line 22, in <module>
    gtk     = import_gtk()
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/gtk_common/gobject_compat.py", line 131, in import_gtk
    return  _try_import(import_gtk3, import_gtk2)
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/gtk_common/gobject_compat.py", line 71, in _try_import
    imported = trygtk3()
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/gtk_common/gobject_compat.py", line 60, in trygtk3
    return import_method_gtk3()
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/gtk_common/gobject_compat.py", line 127, in import_gtk3
    from gi.repository import Gtk                   #@UnresolvedImport
ImportError: No module named gi.repository

Change History (2)

comment:1 Changed 3 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Sorry about that. Something went wrong during the packaging step of the 2.5.2 python2 builds on macos. I'm still not sure exactly what went wrong..

I've published newer 2.5.2 builds, and verified that all the libraries are included this time.
Feel free to re-open if I've missed something.

PS: this did not get caught by the unit tests because the packaging runs after the tests, and didn't get caught by manual testing because the test system has those missing libraries installed... We'll try to do better next time.

comment:2 Changed 3 months ago by miranska

Thanks a lot!

Note: See TracTickets for help on using tickets.