xpra icon
Bug tracker and wiki

Opened 8 years ago

Closed 8 years ago

#239 closed defect (invalid)

Win32 Client has python error on startup.

Reported by: aradtech Owned by: aradtech
Priority: minor Milestone: 0.8
Component: client Version: trunk
Keywords: Cc:

Description

On startup the win32 client displays this error message

"The program can't start because python26.dll is missing from your computer. Try reinstalling the program to fix this problem."

Then hit the OK button and the program runs as normal.

Change History (5)

comment:1 Changed 8 years ago by Antoine Martin

Owner: set to aradtech
Priority: majorminor
Status: newassigned

Does this machine have the GStreamer SDK installed? (I'm not getting this with my development environment which should be identical to yours.. so something must have been done wrong on your setup)

I have also tested the installer on a clean MS Windows XP Pro and Windows-7 VMs.
I am assigning this ticket to you so you can figure out what the difference is with a working system so we can prevent this or know how to fix it if it does occur in the future.

comment:2 Changed 8 years ago by aradtech

This problem happens on both the vm you created for us to make the installers and existing win764 that does not have the Gstreamer SDK installed. So I would think the issue is in the vm. You worked on that vm so perhaps its something you changed in it , that's when sound started working in it at all. Before that I don't remember having that error on startup.

comment:3 Changed 8 years ago by Antoine Martin

Please investigate, try on more VMs, real Windows PCs, etc.
We need to figure out if this happens all the time or just on specific setups.

comment:4 Changed 8 years ago by Antoine Martin

Assuming that this does not happen with the binaries I have just released (http://xpra.org/dists/windows/), please revert your VM to a clean, known-working state and update from there.. (re-install GStreamer, etc).
Alternatively, I can give you an updated VM, but we wouldn't be learning anything from the exercise.

As for, what I did to get the sound working on your VM: it looked like GStreamer was not installed properly so I re-installed it. That's all did, and it looks like the problems remained, at least this one.

comment:5 Changed 8 years ago by Antoine Martin

Resolution: invalid
Status: assignedclosed

Not heard back, closing.

Note: See TracTickets for help on using tickets.