xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 3 weeks ago

#2397 closed defect (fixed)

minor issue collection

Reported by: mviereck Owned by: mviereck
Priority: minor Milestone: 3.0
Component: client Version: 3.0.x
Keywords: Cc:

Description

xpra v3.0-r23575 on debian bullseye.

This is a ticket to report some more or less minor issues that I see, but did not track down properly yet.

Sorry for this less qualified ticket, but I thought I could at least tell you instead of waiting too long until I find time for more investigation. You can open new tickets if you want to pick something up, I'll look at it closer than.

Following issues seen with applications in Docker container (especially firefox). The container setup might influence the behaviour in some cases:

  • the keyboard layout seems to take some seconds until it works properly. My german keyboard layout switches z and y compared to US layout. In the very first seconds after startup I get e.g. y instead of z.
  • Chars like ä ö ü appear as gibberish in window titles. Within the window they are ok. Sample website with special chars: https://markscheid.com/eroeffnung-des-waldbads . A rather cosmetical issue so far.
  • New windows are sometimes slightly too big. I need to maximize them to see the full window content. (Xfce). Might be an application issue and not related to xpra. But maybe xpra fails to detect the real work area for windows.
  • Sometimes window content has crippled lines not redrawn properly if scrolling a website in firefox. Scrolling again helps to redraw. (Yet having the same issue in the ticket editor eating up some written lines.)
  • Inserting clipboard content needs several attempts and takes a few seconds.

Change History (4)

comment:1 Changed 4 weeks ago by Antoine Martin

Status: newassigned

Maybe most important and difficult: application systray icons (not the xpra systray icon) do not appear at all

This is a python3 on Linux only bug (reminder: python3 is still not the default in v2.5.x), it is already fixed too: r22567

the keyboard layout seems to take some seconds until it works properly

Does the server get the correct layout when you connect? (in server log)

Chars like ä ö ü appear as gibberish in window titles.

Funny because the only place where we do care about UTF is for window titles, and all those hundreds of python3 bugs were because python3 forced us to use unicode. Will fix.

New windows are sometimes slightly too big

Is this with Xvfb or Xdummy? Does your vfb resolution match your client's?

Sometimes window content has crippled lines not redrawn properly if scrolling a website in firefox.

That's the scrolling code: #1320, #1232.
There used to be bugs in there, but I haven't seen any for a very long time.
Is this with opengl on or off? Can you try the python2 client? Do you have any scaling enabled?

Inserting clipboard content needs several attempts and takes a few seconds

What application? How do you "insert"?
In which direction? etc.. Is this 3.0 or 2.5?
See #812.

Last edited 4 weeks ago by Antoine Martin (previous) (diff)

comment:2 Changed 3 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to mviereck
Status: assignednew

The window title issue is fixed in r23671. (new beta builds for bullseye and buster)

As for the rest, I would need more info to investigate.

Last edited 3 weeks ago by Antoine Martin (previous) (diff)

comment:3 Changed 3 weeks ago by mviereck

The window title issue is fixed in r23671.

Confirmed, thanks!

As for the rest, I would need more info to investigate.

Of course.

I should note that I get a lot of system updates in debian testing. Some issues might have their cause outside of xpra and get fixed with system updates.

Is this 3.0 or 2.5?

Except the tray issue all issues occured with xpra v3.0-r23575. Now testing with xpra v3.0-r23672.

Inserting clipboard content needs several attempts and takes a few seconds

What application? How do you "insert"? In which direction? etc..

It was inserting into firefox in xpra with either CTRL+V or "Paste" from context menu. I still had the issue an hour ago with r23575, but not yet with r23672.

the keyboard layout seems to take some seconds until it works properly

Does the server get the correct layout when you connect? (in server log)

The issue was consistent about a week, now it is gone.

Sometimes window content has crippled lines not redrawn properly if scrolling a website in firefox.

That's the scrolling code: #1320, #1232.
There used to be bugs in there, but I haven't seen any for a very long time.

Is this with opengl on or off? Can you try the python2 client? Do you have any scaling enabled?

Happened with opengl on+off as well. Tested with python3 only so far. No scaling.
It did not happen all the time, and yet I don't see it. I'll tell you again if it reappears, maybe it is gone, too. Might have been a graphics driver issue instead of an xpra issue.

New windows are sometimes slightly too big

Is this with Xvfb or Xdummy? Does your vfb resolution match your client's?

Tested with Xvfb only. The vfb resolution matches the client resolution.
I am not sure if this is really an xpra issue, would need more investigation.

application tray icon

Here we have two issues:

  • "xpra --version is xpra v2.5.3-r23270 and desktop environment is GNOME3 (Ubuntu 18.04 default)." Reported in https://github.com/mviereck/x11docker/issues/181: The tray icon doe not appear at all. I don't know if it uses python2 or python3.
  • xpra v3.0-r23575: The tray icon appeared, but did not open a popup menu as I opened this ticket. Now (xpra v3.0-r23672, python3) it does.

comment:4 Changed 3 weeks ago by Antoine Martin

Resolution: fixed
Status: newclosed

It was inserting into firefox in xpra with either CTRL+V or "Paste" from context menu. I still had the issue an hour ago with r23575, but not yet with r23672.

If the bug does re-occur, please include the client + server -d clipboard log output.
The client application (in this case Firefox) should be immaterial - so it would also be worth trying to reproduce with something simpler, like gedit or one of the clipboard testing tools.

xpra v2.5.3-r23270

IIRC, the fix for python3 with 2.5.x is in 2.5.4 (which may never get released)

xpra v3.0-r23575

The system tray / tray menu APIs are a complete mess on Linux. Expect more breakage in the future as they relentlessly break their own API time and time again, whilst reducing their usefulness to a point where we can barely use it for anything at all.

I'm going to close this ticket as we near the 3.0 release. Please open new ticket(s) if you can reproduce any of the remaining problems.

Note: See TracTickets for help on using tickets.