xpra icon
Bug tracker and wiki

Opened 2 weeks ago

Closed 2 weeks ago

#2409 closed defect (worksforme)

socket.connect EWOULDBLOCK

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 3.0
Component: core Version: 3.0.x
Keywords: Cc:

Description

This is causing havoc with unix domain sockets, xpra list ends up deleting them when it shouldn't.

No idea what is going on here - kernel bug?

Interesting read: Differences Between Windows and Unix Non-Blocking Sockets

Change History (2)

comment:1 Changed 2 weeks ago by Antoine Martin

Status: newassigned

r23754 will print a warning whenever the server finds that one of its sockets has gone MIA.

Could this have been caused by the socket changes from ticket:2125#comment:11 ?

comment:2 Changed 2 weeks ago by Antoine Martin

Resolution: worksforme
Status: assignedclosed

I can't reproduce this any more!

(the io_callback return value fix from r23759 might have done it)

Note: See TracTickets for help on using tickets.