xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 4 weeks ago

#2418 closed defect (fixed)

Firefox html5 client grab of windows doesn't "un-grab"

Reported by: alas Owned by: Antoine Martin
Priority: blocker Milestone: 3.0
Component: html5 Version: 3.0.x
Keywords: Cc:

Description

Starting a 3.0-r23788 server on Fedora 30... with

xpra start :13 --no-daemon --bind-tcp=0.0.0.0:1234 --bind-ws=0.0.0.0:1237 --start-child=xterm --start-child=xterm --exit-with-children

... and then connecting with Firefox (69.0.1 on Windows 7), left clicking on one of the start-child xterms to move it (is that a grab event?) I am then unable to "un-grab" it.
Keyboard focus is on the xterm I have "grabbed", and I am able to then use a command (like 'firefox' to launch a firefox browser in the session), but I am then unable to interact with the newly launched application (firefox in this example).

Oddly, while the generated Firefox browser seems to have top level focus when I try to "sweep the xterm underneath" (since I have a perma-grab in place, moving the cursor to where the new Firefox browser is, the xterm seems to slide "under" the Firefox), clicking the mouse when it seems to be hovering over a Firefox button has no effect (presumably the click focus is still on the xterm which is displayed as if it does not have top level focus?).

Reconnecting to the same server with a Chrome browser/html5 client, I have no such problems.

No sign of any logs in console or server output. (Is there a debug flag in particular to try?)

Change History (2)

comment:1 Changed 4 weeks ago by Antoine Martin

Priority: majorblocker
Status: newassigned

comment:2 Changed 4 weeks ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Caused by r23788, fixed by r23826.

Note: See TracTickets for help on using tickets.